Problem Saving Files with Rhino WIP

plugin
unhandled

#1
  • rhino6 WIP, incremental save not working
  • saving a file in v5 seems to stop file save at all, with no error message to screen
  • file save does not save file unless saved under new name

(Wim Dekeyser) #2

I don’t understand what you mean with number 2 but as far as number 1 and 3 is concerned, I’m doing that all the time without problems so that must be something specific to your setup. You’ll have to provide as much information as possible. Does it happen with any file? Always? Saving to any path on your machine - local disk versus synchronized disks in the cloud? Safe mode? Etc…


#3

thank you for your kind response.

This happened, saving to my local disk, when
saving a rhino file in rhino 5 format. the error
was repeatable, after a shutdown of WIP and restarting the program, same issue.
When doing an incremental save, the file number
did not increase, and no file was saved; again a
repeatable error, and verified through ‘file
manager’ that indeed no file was saved.

https://discourse.mcneel.com/u/wimwim
November 19

I don’t understand what you mean with number 2
but as far as number 1 and 3 is concerned, I’m
doing that all the time without problems so that
must be something specific to your setup.
You’ll have to provide as much information as
possible. Does it happen with any file? Always?
Saving to any path on your machine - local disk
versus synchronized disks in the cloud? Safe mode? Etc


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/2Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/f867606e3ddc0d412ce4ef43b71dd52205d4b7d048e032ebc211da09059d2898click
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


#4

There has been an uptick in the number of reports of file-saving problems in the last few weeks, so something is going on - perhaps just that more people are using V6 now that it’s in Beta, and running into some previously unreported problem(s), otherwise something has definitely gotten buggy for a small subset of users saving files. Often (but not always) it has had to do with network or sync’ed folder saves…

–Mitch


#5

On the positive side, rhino 6 is much faster than
5; there are several new features worth
investigating, and grasshopper is much faster, in
some of the files I’ve tried, more than an order
of magnitude! 2 minutes vs 34 minutes, which is alot


(Pascal Golay) #6

Hi Mark - is the file in a folder that is being monitored and synced to something like Google Drive or DropBox?

@markz

-Pascal


#7

hi Pascal. I was able to quantify the error. If I
save a grasshopper file, then save a RHINO6 file
with the same base name, then the fiel does not
save. Also, when I try a filename variation, if
the first 8 letters are the same, again no file
is saved, and no error message displayed. If I
save the file with a completely different name,
then the file is indeed saved. I verify now with
file manager to make sure that the file is saved.

these are to my local disk inside my machine, as i do not use the ‘cloud’

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
November 27

Hi Mark - is the file in a folder that is being
monitored and synced to something like Google Drive or DropBox?

https://discourse.mcneel.com/u/markz@markz

-Pascal


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/6Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

November 19
thank you for your kind response. This happened,
saving to my local disk, when saving a rhino
file in rhino 5 format. the error was
repeatable, after a shutdown of WIP and
restarting the program, same issue. When doing
an incremental save, the file number did not increase, and no file was saved


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/6Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/0ed33c01b4d99eedb8282ebcae7e2b2fc4248ab5abd3e159d82334c985a6cbfcclick
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


(Pascal Golay) #8

Hi Mark - - so far I am not able to reproduce this -the exact order of operations may be important - can you please give a blow by blow, for five year olds? Start Rhino… etc.

thanks,

-Pascal


#9

start rhino
load grasshopper
move a few components to GH canvass
save as file “Save-this-and-that” (.gh)
rhino, draw a line
save as file “save-this-and-that”

using file manager, the rhino 3d file is not
actually saved , although the grasshopper is

Emacs!

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
November 27

Hi Mark - - so far I am not able to reproduce
this -the exact order of operations may be
important - can you please give a blow by blow,
for five year olds? Start Rhino
etcc.

thanks,

-Pascal


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/8Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

November 27
hi Pascal. I was able to quantify the error. If
I save a grasshopper file, then save a RHINO6
file with the same base name, then the fiel does
not save. Also, when I try a filename variation,
if the first 8 letters are the same, again no
file is saved, and no error message displayed. If I save


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/8Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/7e27e65bd483439b6c515326c8474e91dc5832726ab582a14c74bcd34ba91c66click
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


(Pascal Golay) #10

Hi Mark - thanks, this works here so far…

How are you filtering the view in Windows?

-Pascal


#11

Thanks Pascal. I use various ways to filter/sort,
usually by date with most recent first.

rhino6wip not finding the file to load, nor is it in windows explorer.

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
November 27

Hi Mark - thanks, this works here so far

How are you filtering the view in Windows?

-Pascal


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/10Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/15f6c8049cb92574654ce19cd3067afd046b6ad7762ce4678092fe7d88929a85click
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


(Pascal Golay) #12

Hi Mark - ok, thanks - just to make sure, have you poked around elsewhere on the hard drive for the Rhino file? Just thinking that you might expect both GH and Rhino to default to the same folder location and not notice they are different.

Does the command line report anything at all? (F2 to see the command history after a save attempt)

-Pascal


#13

Hi Pascal, actually, that is a good idea, I had
not thought of that. trying it, not finding a
file saved. Again, with a new file name, where
the first 8 letters are distinct from a
grasshopper file saved filename, then the file is
saved, and shows up for reload into rhinoWIP.

I appreciate the time and attention you are
spending on this reported issue. Perhaps there is
something peculiar to my installation; I should
just fedex you my laptop and you could have a
look! just kidding, i need the machine

A great product, please keep up the good work! even if there a few bugs

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
November 28

Hi Mark - ok, thanks - just to make sure, have
you poked around elsewhere on the hard drive for
the Rhino file? Just thinking that you might
expect both GH and Rhino to default to the same
folder location and not notice they are different.

-Pascal


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/12Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

November 28
Thanks Pascal. I use various ways to
filter/sort, usually by date with most recent
first. rhino6wip not finding the file to load,
nor is it in windows explorer. []
https://discourse.mcneel.com/u/pascalhttps://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalhttps://discourse.mcneel.com/u/pascalPascal
Golay McNeel November 27 Hi Mark - thank


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/12Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/a545da7f0219adbdee15a66f70c7c8ccf30b6463cff8975667ada6713c0fe16aclick
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


#14

Hi Pascal,

A bit more info on this “bug”. I was unable to
save a rhino file while grasshopper was open,
closing grasshopper, I was able to save the file.
When saving from rhino while GH open, and
attempting to save from rhino, no error message was displayed

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
November 28

Hi Mark - ok, thanks - just to make sure, have
you poked around elsewhere on the hard drive for
the Rhino file? Just thinking that you might
expect both GH and Rhino to default to the same
folder location and not notice they are different.

-Pascal


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/12Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

November 28
Thanks Pascal. I use various ways to
filter/sort, usually by date with most recent
first. rhino6wip not finding the file to load,
nor is it in windows explorer. []
https://discourse.mcneel.com/u/pascalhttps://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalhttps://discourse.mcneel.com/u/pascalPascal
Golay McNeel November 27 Hi Mark - thank


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/12Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/a545da7f0219adbdee15a66f70c7c8ccf30b6463cff8975667ada6713c0fe16aclick
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


(Pascal Golay) #15

Hi Mark - thanks - so far we are unable to make this happen as far as I know. I’m grasping at straws here… does the Autosave command work with GH open? Does IncrementalSave work any better than it did at the time of your original post? (there was one fix in the last week or two).

-Pascal


#16

hi Pascal,

This issue has cropped up again. When going to
save a file as a new filename, or an incremental
file name, Rhino6 will not let me do it. After i
close out and restarting Rhino, same. If i do a
windows level file copy and rename, that works.
After using grasshopper, I have closed out grasshopper, problem still persists

I tend to use a lot of incremental file names,
generating a new file every 1/2 our or so, so I find this bug troublesome.

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
November 28

Hi Mark - ok, thanks - just to make sure, have
you poked around elsewhere on the hard drive for
the Rhino file? Just thinking that you might
expect both GH and Rhino to default to the same
folder location and not notice they are different.

-Pascal


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/12Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

November 28
Thanks Pascal. I use various ways to
filter/sort, usually by date with most recent
first. rhino6wip not finding the file to load,
nor is it in windows explorer. []
https://discourse.mcneel.com/u/pascalhttps://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalhttps://discourse.mcneel.com/u/pascalPascal
Golay McNeel November 27 Hi Mark - thank


https://discourse.mcneel.com/t/bugs-in-rhino-wip/49640/12Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/a545da7f0219adbdee15a66f70c7c8ccf30b6463cff8975667ada6713c0fe16aclick
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


(Pascal Golay) #17

Hi Mark - can you check the setting in Windows Control Panel > Windows Defender Security Center > Virus and threat protection > Virus and threat protection settings > Controlled folder access. Is that set to On? If so, does turning it off change the Save behavior?

-Pascal


#18

thanks Pascal. Norton Security is overriding
Windows defender settings, so can’t check this route.

This was working under rhino 5.0, same folder,
However can;t hurt to check all possibilities.

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
January 30

Hi Mark - can you check the setting in Windows
Control Panel > Windows Defender Security
Center > Virus and threat protection > Virus and
threat protection settings > Controlled folder
access. Is that set to On? If so, does turning it off change the Save behavior?

-Pascal


https://discourse.mcneel.com/t/problem-saving-files-with-rhino-wip/49640/17Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

January 30
hi Pascal, This issue has cropped up again. When
going to save a file as a new filename, or an
incremental file name, Rhino6 will not let me do
it. After i close out and restarting Rhino,
same. If i do a windows level file copy and
rename, that works. After using grasshopper, I have closed out


https://discourse.mcneel.com/t/problem-saving-files-with-rhino-wip/49640/17Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/344451662a597d778fb2b1a4c4ae6422dc997bab7e6cb6d650c361d055cd7b6cclick
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


#19

Some additional info - most of the save errors
seem to be when I am saving a file when there is
a similar file name, or when the first, say, 4
characters of the file name are the same as
anything saved in that directory, regardless of the file name extension.

[]
https://discourse.mcneel.com/u/pascalpascal
https://discourse.mcneel.com/u/pascalPascal Golay McNeel
January 30

Hi Mark - can you check the setting in Windows
Control Panel > Windows Defender Security
Center > Virus and threat protection > Virus and
threat protection settings > Controlled folder
access. Is that set to On? If so, does turning it off change the Save behavior?

-Pascal


https://discourse.mcneel.com/t/problem-saving-files-with-rhino-wip/49640/17Visit
Topic or reply to this email to respond.


In Reply To

[]

https://discourse.mcneel.com/u/markzmarkzhttps://discourse.mcneel.com/u/markz

January 30
hi Pascal, This issue has cropped up again. When
going to save a file as a new filename, or an
incremental file name, Rhino6 will not let me do
it. After i close out and restarting Rhino,
same. If i do a windows level file copy and
rename, that works. After using grasshopper, I have closed out


https://discourse.mcneel.com/t/problem-saving-files-with-rhino-wip/49640/17Visit
Topic or reply to this email to respond.

To unsubscribe from these emails,
https://discourse.mcneel.com/email/unsubscribe/344451662a597d778fb2b1a4c4ae6422dc997bab7e6cb6d650c361d055cd7b6cclick
here.

Sincerely,

Mark Zirinsky
PEMED
6035 E 38th Avenue
Denver, Colorado 80207
USA
1-303-393-7800
1-303-393-1482 (fax)
http//www.pemed.com
markz@pemed.com


(Pascal Golay) #21

Hi Mark - this is another shot in the dark but I would test this with Norton off and see what happens. I’ve asked a developer what he thinks - he’ll certainly have a better idea than me, but since this is a unique problem, to my knowledge anyway, I tend to think there is a peculiarity on your system…

-Pascal