Problem: circle packing

Hi all! I’m trying to use a grasshopper script to pack circles onto surfaces in rhino. when using the surface I developed in rhino I get the error: data conversion failed from brep to surface. I’ve tried fixing this problem by adding a deconstruct brep component which does work to some extent but the offset component still fails and some of the circles end up intersecting in the middle of the surface. I’ve tried creating the surface from a sweep 2 within grasshopper using the same curves I used in rhino which solves the overlap issue but gives me a completely different shape than what I’m looking for and for some reason the offset still fails. Any advice that can be offered would be hugely appreciated!
here’s my files:
ring.3dm (666.3 KB) (17.0 KB)

Without even looking at your files, that error message is telling you that you have a polysurface instead of a single surface.

1 Like

glad that was such an easy fix! thanks!

Fix? That fixes nothing, it merely explains the error message. In fact, that brep consists of six surfaces joined together.

I don’t have a fix.

P.S. You can skip the offset but the C# component isn’t happy:

  1. Warning (CS1701): Assuming assembly reference ‘RhinoCommon, Version=6.35.21222.17001, Culture=neutral, PublicKeyToken=552281e97c755530’ matches ‘RhinoCommon, Version=7.29.23107.3001, Culture=neutral, PublicKeyToken=552281e97c755530’, you may need to supply runtime policy

And perhaps it’s not what you want anyway?

I just rebuilt the polysurface with duplicated edges and it worked just fine.

but maybe you can help with the new problem I’ve encountered :slight_smile:
I’ve changed the script to use imgcircles so I can input color data later on but now my circles don’t lie normal to the base surface. I tried adding a facenormals component but either its the wrong component or I’m pluging it in wrong… you’ll have to excuse me I’m pretty new to this :blush: (15.0 KB)

I see no evidence of that in your file? It apparently doesn’t refer to the previous Rhino file.

Instead of multiple posts, you can edit any of your posts. As I write this, I’m being told:

This topic has been solved

Only reply here if:

  • You have additional details
  • The solution doesn’t work for you

If you have an unrelated issue, please start a new topic instead.

As far as I can tell, it has not been solved? But perhaps you didn’t provide the fixed geometry and now need help with a different problem?

yes that’s exactly it. here’s the new surface:
fixed_geo.3dm (2.4 MB)

I don’t know much about Kangaroo but this looks OK? Need to increase the ‘Min/Max’ values perhaps? (13.3 KB)