Meshing error after join breps


#1

Hi,

maybe this is interesting to debug for you:

getting these 2 surfaces out of grasshopper and after joining the bottom surface won’t shade.

the only thing that helps is removing the inner trim.

the trim curve is an intersection between the two surfaces.
I tried to rebuild and refit it before making the surface split, but it
won’t change the shading problem. So I think it bight be some rare glitch here.

meshError.3dm (966.9 KB)


(Luis Fraguada) #2

Which version of Rhino are you using? Can you attach the definition that generated these? Thanks.


#3

rhino 5 latest SR

files attatched.
should be self explanatory I hope.

if you bake the very right component you should be able to create the dubious geometry yourself.

I added a rebuild crv to solve the issue, these are disconnected at the moment, you can re-wire them.

I also noted that when the meshing fails, the nurbs area calculation takes a long time, sometimes more than a second.

Bugs.zip (288.1 KB)


(Luis Fraguada) #4

Thanks for that. This is more of a general issue with Rhino and not specific to Grasshopper. I tried the same operations with the geometry in Rhino, and the same thing happens. It seems when these two pieces are joined, the render mesh gets destroyed from the lofted surface. I thought it could have to do with the fact your input curves for that loft are Degree 4 curves, but rebuilding them didn’t do anything to sort that out.

@pascal or @Rodri, if you check out the .3dm in the attached .zip, you’ll find a Polysrf where one of the faces (after exploding or Extracting) has a Render Mesh with 2 vertices and 0 polygons. What would cause this?


#5

I cannot add that much, but when using the edge to split the untrimmed surface it works:


#6

When you untrim the hole, the resulting curve has 3 parts.

One of them is
Start = (-22018.9,55948.1,-750.995)
Ende = (-22018.9,55948.1,-750.995)
Domäne = von -145.631 bis -145.631
Linienlänge = 0.000244945

When you remove this piece and trim again with the curve, the shading is ok.