Printing in Mac

When i try to print to paper i only get the standard mac dialog printing box. to get the the rhino dialog box i have to quit rhino and restart it. this happens every time, whether i press ctrl/P or select print from the drop down menu. we are using a sharp MX-4111N printer. i am using a macbook pro with the latest OSX 10.10.5 and my rhino is up to date too.
And i agree with an earlier post that it would be great if the dialog box retained its previous settings to save having to do this every time!


I also have have problems printing in Mac. In an other way: As i try to print in artistic mode or pen mode, and then click on vector output, my Rhino ALWAYS freeze, it opens two small white dialogs (see picture), and i’m unable to do anything excepted cmd+alt+esc and force Rhino to quit

It may be a bad idea from me to try this, but it’s worse than Rhino freeze in this case, or not?

Here is my configuration:

Software information

Software versions
Rhinoceros version: 5.0.2 (5A865)
IronPython version: 5.1.2015.131
Language: fr (MacOS default)
OS X version: Version 10.9.5 (assemblage 13F1112)


Third party kernel extensions
at.obdev.nke.LittleSnitch (4246)
com.globaldelight.driver.BoomDevice (1.3)
foo.tun (1.0)

Hardware information

Computer hardware
Hardware model: MacBookPro9,2
Processor: Intel Core i5-3210M CPU @ 2.50GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel HD Graphics 4000 1024 MB
Memory: 1024 MB
Screen size: 1280 x 800
Displays: LCD couleur (114dpi 1x)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-8.28.36
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: Aucun
Anisotropic filtering: Aucun

I’m unable to reproduce this in Rhino for Mac 5.0.2 on OS X 10.10.5 (Yosemite). I can switch between Raster and Vector outputs for a Perspective set to Artistic or Pen mode. I do not get these little white boxes.

Is any one else seeing this? Especially those running Mavericks (10.9.5 as @pielbri is).

Tried it again this morning: same problem and maybe new information for you: I can move the white boxes with my mouse and one got me its content:
File name: /Users/bozo/Projects/Rhino5Commercial/src4/mfc/
Line number: 105
Code Type: X86-64
Version: 5.0.2 (5A865)

Note that Rhino doesn’t completely freeze: i can still access some menus, for example print. And it then opens a new white bigger box where i can choose my printer under conditions that i find the right place for that:

Hope this helps

@mary Do you see similar behavior on Mavericks on your machine?

Just tried on my Mac with 10.9.5. I see no problems.
@pielbri Maybe try to disable any programs running (Little snitch etc …)