Print to PDF: Creates Blank PDF?

Continuing the discussion from How to create a large (dimensional) pdf?:

I was under the impression that Printing to PDF was working based on the above thread. However, when I issue Print command and choose Print to PDF, I get a document that is blank.

Never printed to PDF from Rhino (Mac or Win) and this isn’t behaving like any other application I’m currently able to do this from. Am I missing something unique to Rhino or this a glitch?

(MacRhino 5.0.2, OSX 10.10.5)

Hi Dave,

I started the thread you referred to, but that concerned selecting a paper size larger than my printer would physically be able to handle. I finally succeeded by installing a “ghost” printer, selecting that in the printing dialog window, creating a custom (large) paper size, selecting my real printer again without closing the printing dialog window, and then “printing” a pdf to that size. A workaround, but it did work.

Are you seeing anything in the preview window in the printing dialog window?


Nope. Blank sheet in the preview. Blank sheet after it’s saved.

Thanks for the response, Max. I followed your issue, which confirmed that PDF’s “should” work, but my issue is different. When you printed to PDF, did you simply issue the print command / print to pdf? (the normal process for all programs) Or some other method?

No clue, what’s going on since all my other programs work in this fashion. Hmmmm…

1 Like

do you have the viewport you’d like to print as the active viewport?

also, bring up the print dialog then click ‘Show Details’

which gives a lot more options… use some of the output & scaling options to try to get your desired view.

Make sure that you scroll to “Visibility” and check that “Only selected objects” is not ticked (or select the objects you want to see)



Thanks for the screenshots, Jeff. Yup, I was doing the same. Max, your tip (pointing to the dropdown menu) allowed me to eventually find the issue. Visibility was not the problem, but Position was (largely, but not entirely) the issue.

For some reason, my default setting for Position > Offset from Lower Left > contained values for X and Y that placed the image in my viewport off the PDF capture screen. I’m wondering if this is the default setting from McNeel—I sort of doubt I changed this since I don’t recall ever trying to print a PDF directly from MacRhino, nor was I even aware of this particular dropdown option)?

Sadly, there remains another problem. No matter how I tweak the settings, the PDF crops off the top portion of the desired elements selected. Here is a Centered view of: 1) the PDF preview (which is resembles the resulting PDF), and 2) a Rhino viewport image of the desired elements.

@jeff_hammond, @maxz: Care to try creating a PDF to see if the enclosed file works on your end?

@dan: Is this a bug affecting all users, or (as my wife believes) do I have some special Cylon super-power that disables technology?

1313-1315_Site_Boundaries.3dm (60.1 KB)

Dave, I cannot reproduce this (with one exception, see further down), with all the margins and positions set to zero, it still produces the full picture in US Letter size:

test.pdf (205.2 KB)

The exception is when you select “Extents” in the “Output and Scaling” option menu. Funny enough, in my case it chops off a section at the bottom.


Edit: One more exception: when you use the “Window” option, and you set your window too close to the bottom what you want to print, the same happens: the bottom gets chopped.

Max, I think I’m homing in on this and it’s starting to make some sense. Another tricky part is under View, but all seems to work properly now, after also fixing the Position and Margin settings:


  • Viewport: shows the entire viewport correctly
  • Extents: shows the full extent of geometry correctly
  • Window: this requires the user to draw a box around the desired geometry, and works properly. However, this can easily create unexpected results—especially if one has drawn a previous window at some point. Maybe this is your issue? (While the “Set” button works for me right now, curiously the first time I tried the Set button, I was unable to exit out of the command. Can’t repeat this now though)


  1. I’m not sure the PDF printing has any bugs (other than the Window > Set function behaving oddly the first time I tried to use it). However, the process seems really fraught with challenges. Are the print defaults set by McNeel? If so, it appears they don’t match expected default behavior in other Mac applications for printing (PDF and otherwise) and perhaps these could be tweaked in a future release.

  2. Under View, one wonders if the word “Region” might be a better term to use than “Window”, since Window is easily misinterpreted in a number of different ways.


No, this was not my issue. I was perfectly capable to set the window ( region?) as I wanted to, but as I explained, when you set the bottom of the window too close to the bottom objects you want to print, the print shows those objects chopped at the bottom. I made sure that I had all of the margin and position variables set to zero. It may be a bug, but somehow it happens at the top of your print and at the bottom of mine with the same input and printing format (US Letter).

I am no too bothered with this phenomena, I use “Extents” mostly, and work the position, scale and margin settings until I get the picture I want. (Note that you can use negative position settings).


I’m guessing your issue is that Brother Cups Driver. Create another printer and use the - Generic Postscript Driver . You can name the printer “Rhino” (or whatever) since it is a stand-in for Save as PDF.

Printer output - Vector
PDF - Save as PDF (bottom left of print dialog)

Attached is your PDF.

Untitled.pdf (26.8 KB)

Yeah… I agree that there is some sort of oddity involved (not entirely sure what that is, though), but with some effort it seems that users can get what they want—eventually.

If the defaults are quirky in the install file (assumed, but not known) and can be tweaked just a little by McNeel in future versions, this alone would make first time efforts to Print to PDF much easier. I’m no stranger to the Mac or Printing to PDF (31 years of Mac wrestling), but was flummoxed enough to post this dilemma! Thanks again for the testing to you and Jeff. ~Dave

Interesting idea. Thanks!

Yea, I’ve got 4 different printers with 4 different drivers, and none of them are exhibiting your behavior when outputting to Save as PDF, so YOUR specific driver is suspect…

BINGO!. Thank you MAXZ, not sure how I missed that box ‘only selected objects’. Not sure how the guy from Rhino I was on the phone with 3 times today missed it either but THANK YOU!