Print settings nightmare close open is required to work it


Ok, draw a box 1070mm wide x 374mm tall and try this !

I need to print to raster my object at full size. its 1070mm wide x 374mm tall
I choose 1:1 scale and the raster option.
window and set, I resize the window to encompass my object and it says alter scale yes no, I have it at 1:1 so no, the window jumps back to the A4 size.
There is no way that one can tell it to print to the size of the window at 1:1 scale, it should be that dragging the window alters the raster dimensions, user then decides on the pixels per inch.

I decide to alter print size to 150cm x 150cm 200dpi 1:1 window click set and I position this carefully over the object, there is a lot of space either side yet I hit enter and the object is part out of the preview window !!! hit set and its fully within.
wasted space and MB’s above and below so alter size to 180 x 80cm yet it still shows the previosu size when use set window.
get fed up and close the print dialog box. Then decide to have another go and open it and behold its now showing 180 x 80cm and set window shows this size.

However I want it a better fit, hit enter and back into dialog box,

I enter 110 x 40cm, the preview changes to letterbox but use windows set and I am still looking at the previous size, resizing the window prompts the change scale so hit enter and it has changed back to 150 x 80cm.

This Print facility needs a makeover. THIS IS NO GOOD AT ALL.

It shouldnt take 30 mins and still be putting up a fight.

I am getting nowhere, it wont let you dictate the size of the window.
Close it down.

Open it again and its now showing 110 x 40cm !

Definitely something wrong, and resizing the window should directly alter the print size.

You have to enter a width and height, then close the dialog window and open it again to see the changes , then you use window set to position the window.

Furthermore I get the result into photoshop and its massive, why, because I created it full size at 200dpi and its opene up as 72dpi, so I have to alter it to 200dpit with sampling off and keep proportions on.


If you want the image for a Photoshop session, you may have more success with -ViewCaptureToFile (hyphenated)

and if the resolution is not as good as you would like, multiply your width and height settings by 2 or 3 then scale back down in Photoshop.

I agree, there does seem to be a bug there, @stevebaer when printing to an image file the “paper” size does seem to reset itself to the last used value… It looks like you actually have to set the print dimensions, then hit “Close” in the print dialog, then call Print again to get the settings to stick…



Hi Mitch,
Bug…more like something from starship troopers !

For png jpg etc, we need to be able to go window…set , resize the translucent rectangle to encompass the object, and that should alter the mm or cm values in the print dialog, so when we hit enter we now see what we need, alter dpi if need be, keeping an eye on Mb file size, choose print and thats it.

Bug needs splatting so as to get that !

Also choosing 200dpi I want my image to e 200 dpi, not 72dpi when I look at it in photoshop.
It ceases to be 1:1 if the resolution changes.

so TWO bugs, the latter even worse. Can you reflag the TWO bugs to Steve ?

How does one post a video by the way ?

upload wont handle the sizes.

BrianM…just tried that, trouble is width and height you have to establish, so draw a rectangle, write down the figures, type w enter width etc etc, its a bit long winded but worth remembering, the I have to resize it by going three times as big to get the resolution, the maths are starting to clash in my tired brain.

I just wish to quickly drag, choose 1:1 and jpg and be done.


Hi Steve, FWIW, I use this method a lot and you get a really good feel for the finished size just by zoom and pan, you know which parts of the screen will not be included in the finished exact size, and by having windows explorer open and reviewing as you go - also gives you file size etc. Its quick to over-ride if you’re not pleased with the result.

Should have mentioned the Width and Height are in pixels so multiply by 3.78 for mm