Print dialog is useless..just what needs doing to get a landscape shape print?


#1

Hi,
V5

this is so fundamental and basic a need and it doesnt work.
1 hour (at 4am so this is bad news) spent trying to get landscape shape print, choose jpg/tiff, type width 297 and height 210, 200dpi
hit window and set and it shows portrait.

Try as I might it reverts to portrait and doesnt even make the dims 210 and 297.

I in fact want A2 but it does the same for that, so I tried for A4 then hoping to scale larger the window.
print dialog is impossible, third time messing about.

HELP !!!

I see this is similar to the issues I had in June 2014 which was said to be a bug, but it still exists

Steve


#2

@stevebaer I agree this looks completely buggy to me. If you are printing to an image file, it always resets to portrait. The only way I see to fix it is to first use another printer (desktop or PDF) and set it specifically to landscape and the size you want, then before actually printing, switch back to image file. The landscape and size settings will stay that way - but don’t try to change them, it will revert to portrait.

Steve1, for a short-term solution to this, I’m afraid you’ll need to bite the bullet and install a PDF printer.

–Mitch


#3

Hi, It would seem the raster option in print is completely riddled with bugs. I closed the comand eventually then went back in and got a landscape but I cant seem to nail it when I use it again later on, I wanted A2 and choosing one of the printer optind didnt give A2, it knows what the printer is capable of, its as if I need to install drivers for a flatbed printer or banner printer !
I tried the other method of ViewCaptureToFile but it didnt even give me any options, it just created a screen shot as such.

This truly needs fixing, such basic stuff failing in V5.

I got to bed 7am thanksa to the fun and games, when everyone else gets up !

PLEASE FIX THIS. THIS SHOULDNT BE AS SUCH BY NOW, IT SURVIVED V4 AND THRIVES IN V5 STILL.

To have also the ability to drag out a box and have it fill width and height with the dimensions would be a godsend. To keep messing about with values until one gets a box that encompasses the view is nuts.

What was that pdf bug free ad free etc rock stable pdf driver you were using Mitch ?

I still need to print raster, I just hope it fixes the bugs.

Steve


#4

@Steve1
on my Version 5 SR10 64-bit
(5.10.41201.11145, 12/1/2014)
this is what I do, very simple fix:
print, image file, set pixel size desired, then CLOSE the print dialogue using button at bottom right.
Now print, you’ll see pixel size is set to what you had it last (landscape, portrait, doesn’t matter)
Now in the view and output scale tab, hit ‘set’ and window your drawiing/model area you want printed.
The preview will NOT be accurate. Don’t worry, hit print. Now check out the image in windows/open it up. It should be exact dimension you specified, windowed exactly the way you want it.


#5

You need a hyphen prefix Steve, and don’t forget units are in pixels;


(Steve Baer) #6

I logged this in youtrack at
http://mcneel.myjetbrains.com/youtrack/issues/RH-30302