Post optimization processes

Hi!
I’m doing my dissertation and it’s related to topology optimization. Currently, I’m using the “BESO for shell” function a lot, available in Karamba3D software. I was wondering if there is a way (an plugin or some code) to extrude the optimize structure (only the optimize shape) without having to bake and redraw with spline command or others.

For example, I have this optimize structure (below):

And I’m changing many inputs like mass ratio, or the position of the load’s/constraints, or even the load magnitude it self, and instead of having to “bake” all the time in order to do the analyze after, I would like to have real time data while I’m changing those inputs…that would help me a lot!

Do any of you have some suggestions?

Thanks!

Hi @gustacsilva,

you can use the Isolines component to draw the lines at certain cross section thicknesses.
Please refer to: https://manual.karamba3d.com/3-in-depth-component-reference/3.6-results/3.6.12-line-results-on-shells#isolines-on-shells
best,
Matthew

Hi @matttam,

Thanks for the reply. So i was trying to do that, but i just can’t make it work, don’t know why. Can you help me? Here is the grasshopper file Beam optimization - BESO for shell.gh (45.1 KB) .
I woud like to extrude only the optimized structure.

Thanks!
Gustavo,

Hi @gustacsilva,

there seems to be a bug in this component which we are trying to see what the issue is. However as you have a simple surface, you can use a Mesh|Plane component to perform this too:

Hi @matttam,

Thanks again, let me know when the bug be fixed. Can you tell me the name of the component you mentioned before (the mesh|plane component), i can’t find it.

Just one more thing, i saw on yours online manual that it’s possible to export files to ifc. So was trying to do that using the “ggkarambaexport” command, but it’s giving me this error “1. Solution exception:Method not found: ‘Int32 Karamba.Models.Model.get_numLC()’.” As you can see below:

Do you know why?

Also, it is possible to export to others files? I mean, i want to run a non linear analysis with the optimized model in an external software, like ansys and others. Can i export to others formats, like STL for example.

Sorry for all this question, but would help me alot,
Thanks again!
Gustavo,

The Mesh|Plane component should be in in the intersection components.

The ggkarambaexport components are from GeometryGym so you will need to contact them for licensing. At the moment you can export to DSTV format natively in Karamba.

1 Like

Thanks @matttam!

I will try to export to DSTV and see if works then. I will contact them too thanks.
Just one last thing! I tried the mesh|plane component following your example in the print screen you sent and didn’t work. Can you tell me what a did wrong?

Thanks again @matttam!!

Hi, @gustacsilva, you need to set the value of the slider to suit your mesh. You need to double check the mesh thickness as the grasshopper units are not the same as Karamba units (geometry is in m, but cross sections are in cm). Also i noticed that your model is approx 250m long. Is this correct?

Hi @matttam!

Yeah…i had the the length of the model wrong…i already correct it to a reasonable value.
Regarding the value of the slider, adjusted it according to the thickness of my cross section. As you can see below it seems to work:

Thanks man! I really appreciated it!

So, after that i did this combination of commands (check below) in other to have the optimized model as a solid:

As you can se in the next print i got a reasonable result:

So my question is if you know some others commands that can give me an more perfect solid.

Thanks again! Really helped me here!

You can try to rebuild the curves for example to get a smoother result before extruding it or increasing the mesh density to get smaller mesh faces but then this will increase calculation time.

Hi @matttam,

Yeah thanks for to suggestions. I tried to increase the density of the mesh and got a better result, thanks!

So after that did the “loft” command as a did in the last optimize structure but i got a kind weird solid, like this:

So I tried to play with the different settings of the “loft” command, but got no decent result.
Sorry for bother you again, but do you have any suggestion for how I can make a closed solid after using the “mesh|plane”?

Thanks again @matttam