Point clouds and clipping planes

I have a problem/request. I brought in a point cloud from a client. It had points I did not need. I created a clipping plane so I could see an area of interest I wanted to alter. I then went to Curve/Point Cloud/Remove Points. I selected the point cloud then I used the Select Points/Lasso Points tool, selected the points I wanted, hit return then delete. The points were gone, Great! However, when I turned off the clipping plane, all the points that were behind the clipping plane where I was orientated in the view were also gone.
Frankly, I don’t think the point editing/removal tool should work that way. Shouldn’t it be when using the clipping plane anything that is hidden would also not be included in the selection set? And if you agree, I was wondering if you all could fix that for a near future release. You probably should have a main menu item for points as well like some of the other main functions, just saying.
Regardless, I had to stop what I was doing, re-import everything and start again from scratch and I might abandon using that tool in the future even though it’s much more efficient than V5.
Anyway, thanks for listening.

Hello - I see that, thanks for pointing it out. The problem looks like it is in Lasso - a Window selection respects the clipping.


RH-57262 is fixed in the latest WIP

Super! Thank you!

Hi Brian,
I was working today on a point cloud today with several clipping planes and using the following from the main menu:
Curve\point cloud\remove points and using the lasso points tool. Again, the lasso point tool is not respecting the clipping planes again. This is the version I am using.

Version 6 SR28
(6.28.20199.17141, 7/17/2020)

Thanks for your help
Chuck Rogers

Hi Chuck, the fix was put into the Rhino 7 WIP, not 6.28. Please try the WIP to see the fix.

Hi Brian,
Well, I’m not seeing it work correctly yet (Rhino 7 Evaluation). Here is an image where I’m using the select point tool to grab some 3D faces (Mesh/edit tools/extract/faces) on a mesh where a clipping plane is being used.

This is before I turn off the clipping plane.

For clarity

There it is when the clipping plane is turned off

This thread is about point clouds, not meshes. I’ve logged your separate bug for meshes:

Ok, but with all due respect, it seems to me this thread might be more about the lasso point tool not respecting the clipping plane in general because it was first noticed with point clouds, now it’s with meshes. Just saying. But in any case, I look forward for the bug fix. And thanks for addressing the problem.

Yeah, I get it. It turns out that lasso selection of point clouds was hard to fix - but fixing meshes is really hard to fix. So, it might not happen any time soon. Sorry!

Too bad, it’s a great too.