Plugin version in R5 vs R6

We develop an in-house plug-in in Python that is compiled into an RHI with the Script Compiler.

The plug-in properties would show a version such as 1.0.6710.28824. This is in R5

In R6, the version is shown as 1.0.0.0. This is inconsistent, and causes issues with our update check that we run when Rhino launches.

Hello McNeel,
is really no-one addressing this bug that was introduced in R6?

Is this something you can look at, @Alain?

Would it be possible for me to see your plug-in to try and reproduce the problem?

Here is a very minimal plugin showing the issue we’re having

WB_Test.rhi (4.9 KB)

It adds the command OpenWebBrowser_test. Happy to send you the .py and .rhc files.

The versions is shown as 1.0.0.0 in R6

In R5, I just found out that the version is either ‘Unavailable’ or shown correctly, e.g. 1.0.6710.28824. I hadn’t noticed before that this doesn’t always work. I could swear that when I tested this last week, it worked. It also worked first thing this morning. However, I’ve just restarted Rhino 5 several times, and now it always comes up as ‘unavailble’.

How are you setting the version number? I am walking through the code that loads your plug-in in V6 and see that the file version for your plug-in is set at 1.0.0.0 which is what Rhino uses to display your version.

The version is set by the Script Compiler and set to the compile time.
Also I’ve just checked this again in R5: Sometimes, the version is shown as (encoded) compile time, and sometimes as ‘Unavailable’. I am unable to reliably replicate this behaviour.

Please see


on how I managed to extract the version number in Python.