Please put "GrasshopperUnloadPlugin" back


#1

In Rhino 6 / GH 1, the “GrasshopperUnloadPlugin” has dissappeared.
This is a big problem for me because I often need to kill a GH session.
The reason is that most of my definitions have a specific component that hides the GH interface, and the only way of bring it back is to kill it and open it anew…

Maybe there’s a new command for this, but I can’t find it.


(David Rutten) #2

That sounds like a really nasty component. Running the _Grasshopper command again should show the window if it was hidden, if something is preventing it from showing, I’d very much like to know what that something is.


#3


(David Rutten) #4

Running the _Grasshopper command brings the window back out of minimized state for me. Doesn’t work for you?


#5

Well, actually yes, but not always.
Even simply minimizing the usual way sometimes hides the interface and it can not be summoned back.


#6

Hi David,

Any thoughts on this maximizing problem ?
Will it be solved in GH 2 ?


(David Rutten) #7

I don’t know what’s causing it. Since GH2 will be build on an entirely different UI platform it is unlikely that the exact same problem happens again, unless it stems from deep within the bowels of the Windows OS.

As far as I know there’s only so many ways in which a window can be not visible on winforms, and the _Grasshopper command tests for them all. But clearly under certain conditions something happens that I’m not handling.


#8

I’ve had this exact same issue of Grasshopper disappearing when minimized. Running Win 10 Pro v1709 - 16299.192 - Rhino 5 sr14 64 bit - Grasshopper 0.9.0076. As I am working, I minimize Grasshopper to check the preview; sometimes I see the minimized 'Hopper and sometimes not - within the same session. Running the _Grasshopper command does not bring the window back. The most reliable way to get it back is to minimize the Rhino window then Alt+Tab to bring Rhino back up. Voila… there is the 'Hopper just like you would expect.


(David Rutten) #9

If you’re running 0.9 on Rhino5 then you won’t have the most recent fixes. The _Grasshopper command was improved a couple of months ago to handle more invisible-window cases. This problem needs to still happen on Rhino6 before it even makes sense to look into it.


#10

Thx David. We must continue with Rhino 5 for a while yet so i guess the problem will persist. No biggie, just annoying.


(Arkadius Belov) #11

Hi, if this means the grasshopperunload command will not be available, please reconsider, it can be usefull say to kill grasshopper when the window is unresponsive due to a heavy display preview, or some plugins wont work unless grasshopper is restarted, cheers


(Wim Dekeyser) #12

Have you tried _GrasshopperReloadAssemblies?

See this thread for more information:


(David Rutten) #13

It sounds like what you need is a command to purge or disable the currently loaded file or all files.

The problem with UnloadPlugin was that it didn’t in fact unload the plugin, and it did a lot of additional stuff that caused all sorts of problems. If the UI becomes so heavy that the only thing you can still do it run a command, then we need to figure out what the least amount of work is that command can get away with to solve the problem.