Grasshopper minimized... can't find it

So I was following a long with some tutorials. I finished the set I was watching, saved my GH & rhino files and started new ones. But I minimized the Grasshopper window and now it’s gone. If I run Grasshopper in Rhino it doesn’t bring the window back up.

Edit: Oh, I found it… as a slim line at the very bottom of the screen. Is there an easy way to minimize and maximize Grasshopper (a shortcut perhaps)? It’s difficult for me to click on once I minimize the window.

Because Grasshopper is a child window of the Rhino application, minimizing is an awkward operation. I personally prefer to double click the title bar of the Grasshopper window to fold/unfold it.

Do note you can always close the Grasshopper window without losing any work, closing the window does not close Grasshopper itself. You can then bring the window back by running the _Grasshopper command again.

1 Like

Thanks David, I didn’t realize I could close it as long as I kept Rhino open. That’ll help alot.

Hi,

I find myself quite often in situations where GH is open but no where to be found, including after running the “grasshopper” command in Rhino :frowning:

I recognize this problem but never reported it, now I think about it. What I usually need to do is click on the rhino button on the task bar to make it pop up again or minimize rhino and maximize it again.

1 Like

The minimize-maximize trick has worked sometimes, but these days, it does not.
Maybe it’s got something to do with my UHD external monitor ?

I noticed the GH window disappearing sometimes at random. I never minimize the window so it’s not related to that. However clicking on the Rhino title bar seems to always pop GH back up again.

I’ll have a look to see if I can make the window reappear with more consistency when the _Grasshopper command is run.

1 Like

Hi David,

On my side, it is often the case that the GH window will not re-appear, no matter what…
Only solution in those cases is to close everything, and open anew.

So even running the _Grasshopper command again on the latest WIP will not retrieve the window? I added extra functionality a few weeks ago, but those fixes may not have addressed the actual bug you’re seeing.

Hi David,

I mostly use GH with V5 because of those pesky display pipeline bugs with Human and a general dis-trust with Rhino V6.
Maybe this problem does not happen in GH 1.0 ; I couldn’t tell…

Has anyone had additional problems when using Windows 10 and HumanUI?

I have a consistent, repeatable problem that if I minimize Grasshopper, it disappears completely, right away – does not dock in the lower left-hand corner as it does in Win 7. This also happens with the non-minimized Grasshopper canvas, it disappears when interacting with the HumanUI. I then have to minimize Rhino, and then manually reselect the Rhino window from the taskbar (Alt-tab works occasionally but is unreliable).

I am using Rhino 5, SR14, GH 0.9.0076, and HumanUI with 2-4 WPF windows open. I think this may be a HumanUI conflict/problem. Anyone else having this issue with HumanUI-enabled scripts?

Marc

That’s exactly what I am seeing.

I’ve just had the same problem. Don’t know if you still do. I couldn’t reopen my GH by just pressing the command. What I did was almost closing Rhino, but just before saving it, pressed Cancel and then went back to Rhino and had a little bar from which I could maximize Rhino again. Little silly, but this worked!

Hi Emma,

In Rhino V6, I find that I can consistently bring GH back in focus by running the “Grasshopper” command.

1 Like

Here is the solution! :raised_hands:
(it just happened to me)
pull the lower bar from windows upwards while being on rhinoceros, and it will appear, then lower it:

I hope this helps :smiley: have a nice day

I often have the GH window disappear but its only when the definition has a long compute time… once the model has finished calculating the GH window disappears but if I click on the Rhino icon in the taskbar then GH reappears. Just one of those weird Windows things.

1 Like