Please fix toolbars bug!

The company I work for is selling Rhino licenses from quite a long time.
As far as I know, Rhino has always had a bug related to toolbars: they simply disappear, expecially after a Rhino update.
Please please fix this problem!

1 Like

Hi Sebastiano -

Does this happen reliably? Are there specific steps that I can try to reproduce this issue?
-wim

AFAIK there is no way to reproduce the issue.
I just can say that, in most cases, it seems to happen after a Rhino update.
Sorry I can’t say more but I’m facing the problem just when my customers bring it to my attention.

If your customers are customizing their toolbars, make sure you tell them to save the toolbar layout under a new name - not default.rui - and to back it up elsewhere as well. (just like you would do with any important file).

Thanks, @Helvetosaur!
We use to save custom toolbars during first setup phase… But you are saying that they may be deleted during Rhino updates?

In principle, none of the .rui files are supposed to get overwritten during service release updates - including default.rui. You might have seen that the people who had the WIP and then installed V7 final had to do a ToolbarReset to force Rhino to update the default.rui to the latest version.

However, as that is the only .rui file that Rhino might try to install, and thus by some quirk accidentally overwrite a customized default.rui file with a base default one, it is a very good idea to rename any customized workspace so that can’t possibly happen.

Note that on Mac Rhino, you cannot customize the default workspace - it is simply not allowed, you have to make a copy. This would not be a bad idea on the Windows side IMO - although it would probably get some flack from people who are used to changing stuff around without thinking about what might occur if they don’t safeguard their customizations.

Another note on your use of the word updates - installing service releases of the same version should not affect customized toolbars at all as per the first paragraph. However, installing a version update (V6>V7 for example) does install new, default toolbars - in a different location. It will not wipe out any previous version’s toolbars, but it will not take them over either. If you want to do that, you have to do that manually.

CTRL+H
Replace all occurrences of “updates”
With “service releases”
:wink:

Thanks for your useful tips!
In my opinion, anyway, we’are still experiencing a behaviour that i could consider a bug.

It’s entirely possible - there have been toolbar glitches in all Rhino versions since about V3 or so… However, unless you can find a way to reliably repeat the problem it generally can’t be fixed - because nobody can trace why it’s occurring.

Also you said this:

What does that mean precisely?
The default location for the .rui files is:
C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\7.0\UI (or 6.0, or 5.0)
So, which of the following applies when the problem occurs?

  1. There is no default.rui file at all in the location above?
  2. There is a default.rui in that location but it is not loaded in Rhino?
  3. The default.rui file is actually loaded in Rhino but all the toolbars have been closed?

Maybe the answer to the above can lead us in the right direction…

Yes! That’s exactly what I mean!

As a developer, I completely disagree: that’s not always possible to reproduce the situation that leads to a bug. Nevertheless the bug exists. It is responsability of the developers to try to fix it, even if I understand that’s non easy, without precise information. But that’s just my opinion… And my developing philosophy.

It means that all RUI files (default.rui and others RUI files) are still present inside the default folder (and in other forlders) but it seems that Rhino doesn’t load them. Please note that, sometimes, just external (non default) toolbars seems not to be loaded.

Yes, however if you can’t reproduce it, it’s very hard to find out where in a long and complex code, that it fails. You as a developer probably also know this.

So that means when you go into Options>Toolbars, that this window is completely blank?
image

I have had problems with toolbars all through V5, having the .rui actually loaded, but all the toolbars closed - usually you got a command line message “root element missing”. Somewhere in V6 it got fixed. I have not had that particular problem happen in a long time. There are still a couple of docking issues in V7, but so far I haven’t seen anything major.

There are many threads on toolbars here, I dug up two below but they both concern V5 (i.e. are pretty old):


Thanks again for your help, @Helvetosaur.

As far as i remember, toolbar files are shown in that window. I’ll check next time i’ll face the problem.
Obviously, i’m aware that solving this issue is not easy. Anyway I can’t believe that Rhino developers (that must be very skilled) cannot fix it. In addition, just to let you know how serious this problem is, keep in mind that a lot of our Rhino user are scared every time they could install a service release and, in some cases, they refuse to update the software to avoid problems.

Actually I’ve the problem that my layer, properties window and some toolbars daily appear in different sizes and positions.
Very often it looks like shown in the first screenshot, it should of course look like in the second.
Other combinations of the three groups did also appear.

Hello - does this happen every time? If so, does it help to close all but one toolbar file in Options >Toolbar?

-Pascal

Hi Pascal,

before it happened every time when opening Rhino. Now it does it unregularly.
I have only one rhino toolbar and two plugin toolbars as shown in the screenshot.
Right now I installed todays update and the toolbars stay in place after reopening.

Thanks for the moment…

No. It seems quite random