Performance slows significantly after using Rhino for 1.5 hours or so

Does anyone else have this problem, and if so, do you have a fix please?

This happens on moderate sized files (3 MB), and the only cure is to shutdown Rhino and restart. The interface response gets noticeably slow, the auto complete in the command line also gets slow, and things like selection get very slow as well. Basically everything slows right down, like I was using an old slow computer (which I’m not).

I’ve tried disabling external plugins that I’m not using (eg VRay 2) but the slowdown still occurs. Generally, I’m using a point cloud plugin (Arena4D or Pointools) but the slowdown still happens when I’m not using them. This problem occurs on both laptops and desktops, with both NVidia and AMD graphics cards, all with the latest drivers and the latest Rhino updates, and has been happening since about May this year.



What is the Rhino memory use which is shown at the bottom of the screen, right side?

Do you have any anti-virus software installed which might be doing automatic virus scans or similar?

The symptoms sound like a compounding memory leak in one of the plug-ins.
Watching the memory usage is the key.
In addition to the tool davidcockey described, I use a Desktop Gadget called AllCpuMeter to keep track of what’s going on.

If it is related to one of the plug-ins, it will have to be reported with details to repeat the problem, to the plug-in developer.

Thanks for replies.

I’ve not checked the Rhino reported memory usage but will do so next time it slows. I’ve just checked the files I was using and its about 1 GB on loading, and rises to about 1.5 GB, and the system has 32 GB available.

I have AVG anti virus but I’ve never found it to be at all instrusive - that’s one of the reasons I have it.

I will try AllCpuMeter, thanks for that.

I have just done a few tests using GPU-Z that seem to show Rhino or a plugin holding onto GPU RAM, to the point where it becomes full. Could that be the cause of the problem, and if so, is there a command I can use to get Rhino to flush / release that memory and effectively start from fresh without restarting Rhino?

This is what I found from GPU-Z:
*when the performance had become so slow I had to stop (but before I closed down Rhino), my graphics card was working at about 2% when I tried to do a 3D orbit, but the GPU RAM was full (3980 MB of the available 4GB)
*when I closed Rhino, the GPU RAM load dropped to 200 MB
*when I reopened the same drawing and pointcloud data after a Rhino restart, the GPU RAM rose to 210 MB. After quite a lot 3D orbits and zooming in and out of the data, where the GPU was working at up to 50%, the GPU RAM load had risen to 400 MB - I think that what is happening is that the GPU RAM just keeps getting added to, rather than flushed / replaced (I don’t know how memory works - is that possible?)
*I tried a different but much larger, more complex, drawing, without any pointclouds. After loading, the GPU RAM was at 350 MB (I was looking in a shaded viewport). Some 3D orbits got the GPU running at up to 16%. Then I changed the display mode to rendered, and the GPU RAM went up to 700 MB (there are textures and materials in there, and a lot of lights). I then changed the display mode back to Shaded, and to Wireframe, but the GPU RAM load only dropped slightly if at all (about 2 MB. Then I just swapped between various display modes I thought would need RAM (Artistic, Pen, XRay, etc), and the GPU RAM just kept getting added to - it wasn’t long before I got to 900 MB - so over a couple of hours I can see how it would get filled up.

I’ve got GPU-Z logging now, so let me know if that data would be helpful and I can send it over.



I was curious what is your maximum number undo’s is, and how much memory is allocated to it?

I was also wondering how much system memory you have.

@JonnieGodfrey I have this memory leak problem with a plugin I use. The developers of the plugin say that it cannot be fixed without a total rewrite which they also say they are doing. Hopefully yours will be able to fixed more easily.

I constantly have to watch the memory usage and restart when required. Generally if I am down to 2GB of remaining memory I restart otherwise things just get too slow.

There is an old Rhino memory leak too - updating blocks cause an increase of the memory usage. I’m not sure, but I think it’s not fixed yet.

Undos is at the default - I just checked and the settings are min number of undos = 1, max memory used = 256 MB

System memory is 32 GB, graphics card is a Quadro K3100M which has 4 GB RAM. Same problem on Win 7 and Win 8.1, and am using Rhino 5 64 bit. Same slowdown problem on a desktop with 32 GB RAM and an AMD W7100 with 8 GB RAM (but I’m wishing I’d got an NVidia card for that).

I checked the Rhino reported RAM usage / RAM free - it doesnt get much above 1.5 GB used, and there is usually about 27 GB available.

Sochin - is your problem with the system RAM or the GPU RAM? Do you mind telling us what the plugin is? The only other non-shipped-with-Rhino plugins I have are VisualARQ and VRay 2, is it one of those?


Which version and release of Rhino are you using? 32 bit or 64 bit?

@davidcockey the problem is system ram usage and the plugin is TDM`s Clayoo. It just takes more and more until Rhino gives you a message that it has ran out of ram.

Looking forward to the new rewritten version that TDM have promised….just not holding my breath.

I use the 64 bit version Rhino 5 unless I need a ‘clean’ (no plugins) version, when I use the 32 bit version.

I also have Clayoo, though I dont use it very often. But it is installed on one of the machines where I noticed the slowdown.

Does anyone at McNeel who knows about OpenGL have any ideas please? Thanks, Jonnie

@JonnieGodfrey , does the slow-down occur with 32 bit as well?


Hello Pascal,

I think I have - I have to use 32 bit Rhino 5 it if I need to use the Pointools plugin (which is for Rhino 4 and so is only 32 bit - it deals with large pointclouds), but I’ve not used that plugin for a few months as I’ve moved to the newer Arena4D plugin, which works with the 64 bit version.

Recently I’ve only used the 32 bit version for about 15 minutes at a time, so I’ve not had the slowdown problem.