Rhino slowing down after some time


I’ve noticed how Rhino comes to a crawl after some time of working with large files.
Quite a lot of scripting is involved as well.

After a system restart files run smooth again.
Where a file before a restart took minutes to run a showselected command after a restart its quick again.

Is that expected or is this something that should not happen?


Hi Willem - just as a test, can you try, the next time this happens, resetting the script engine from the Python editor? (Tools menu) I don’t expect that will fix it but it would be a clue if it does…


check! will do

I thought the same after my post, yet my partner had the same without running scripts ( is suspect)

I’ll update if I find any clues.


Another thing to be on the lookout for is memory leaks. Current memory use can be viewed using the Windows Task Manager on the “performance” tab. Once all the physical memory is used up Windows will start swapping to virtual. This REALLY slows everything down.

Thanks. I’ll check on that too.

However I’ve never seen the full 32GB being used.
Could it be there is some exotic setting that limits a process’ allowed RAM or some other obscure limitation?

Thinking about it, maybe the GPU is the bottleneck.
@jeff may I ask you what happens if I have multiple instances of Rhino open with quite a lot of geometry.
Will it possibly make Rhino less responsive because GPU memory is insufficient en data needs to be “swapped around”?


Multiple instances of Rhino is no different than multiple applications all using the GPU… That’s handled by the drivers…and each process should access to the GPU memory and the drivers will manage the context switches accordingly… The only thing you might/should see is a delay when switching over to one of the instances…but from there on out, any active Rhino should behave ok… However, Windows GUI elements might have an impact since those are limited resources.

The next time this happens, try running ClearUndo… to see if freeing up any memory brings things back…but as you pointed out, you’re not seeing the memory peaking, so I’m not sure atm why something would all of sudden just slow down.


1 Like