Pdf printing crashes if printing layout with perspective detail view

Hi all you clever people out there,

My first post, I have a curious problem.

If I attempt to generate a pdf print of a layout which includes a perspective detail view then the process crashes. The exception is if the perspective detail is wireframe in which case the pdf is generated correctly. All other flavours of perspective detail view (shaded, rendered etc) result in a crash. The nature of the crash is that the printing dialogue window freezes when the progress bar reaches 100%. Nothing else happens. Clicking the cancel button on the print dialogue window causes the button to appear pressed then again nothing else happens and no other Rhino button (on the main Rhino window, now in the background) is functional. At this point, if the main Rhino window is minimised and then maximised then Rhino springs back to life, but no pdf has been generated.

I have tried this with 2 types of pdf printer: Bullzip and PrimoPDF, both giving the same result.

Rhino version is Version 5 SR12 64-bit, OS is Windows 7.

Any thoughts anybody, either as to a fix or an alternative method of generating pdf files?

Hi Tomtittot - is this specific to one file? If so, please post or send to tech@mcneel.com (confidential). If the file is large, please send via Rhino3d.com/upload



Just discovered something further.

When the crash has occurred, if I switch to another application which is already running, such as a web browser, after a couple of seconds the 3rd party pdf printer dialogue box appears, together with the 3rd party taskbar item. At this point I can select the output file name and the process completes as it should, generating the pdf file.

So, it appears that the task of invoking the 3rd party printer hangs (together with Rhino) until another application is invoked. Both of the pdf printers behave differently with other applications, with the 3rd party dialogue appearing correctly without having to jump to another application. Hence I have a workaround but Rhino seems to be causing very odd and confusing things to occur. I only discovered the workaround by accident by jumping back and forth between Rhino and a web browser whilst writing on this forum.

Hi Pascal,
Problem does not seem to be file specific. I’ve just started with a new file, created a couple of simple 3D shapes, created a layout - same behaviour. I’ll try the same on another machine later today.