Rhino crashes when I Ctrl+P

Does anyone know why this might be happening? I recently added two buttons to my toolbar, but don’t think this would be a reason for rhino to crash when i’m trying to print images of my model.

Hi Tedrick- what printer driver are you printing to? Acrobat, by and chance?

-Pascal

As soon as I press ctrl-p Rhino goes non-responsive, I don’t get the option to choose my driver. I would like to print to file, but any collection of any imagery is out of the question. I’m having to resort to Window’s Snipping tool, which I loathe.

Also just installed Neon, not sure if that might be related to the issue.

Hi Ted- if you are printing a Neon viewport, Neon may have to re-render the scene- though I don’t think it should be unresponsive with no feedback - I’ll try a test here Meantime, try printing a regular rendered display… any better?

Yeah, it looks like printing from a Neon viewport kicks off at least one, maybe two, extra renderings - not sure what is up there, I’ll test some more. VIewCaptureToFIle should get you what you want though.

-Pascal

Well, im not actually using the Neon viewport to print from, I’m just trying to print the Shaded view but that isn’t working either. So far, I cant print from shaded, wire-frame, neon or rendered, haven’t tried any other.

Hi Ted- what is the printer? Does ViewCaptureToFile help, for now?

-Pascal

Pascal,

ViewCaptureToFile works perfectly. Funny thing, now that I’m looking, it seems this problem extends beyond Rhino. My devices and printers window wont load anything, so checking my default printer is out of the question. I am on a work computer attached via hard-wire to a network with multiple printers available. It makes no sense that I should be disconnected from this information.

Hi Tedrick and Pascal.
I have a similar problem with Rhino.
Rhino seems to freeze and crash when i try to print my work in it… any idea why?
the ViewCaptureToFile Works perfectly for me as well. no problems in that.

a little info on what i’m working on.
i have a PDF file of a building scematic that i’ve imported to Rhino and put in some 3d wireframe objects to display what we are going to mount in the building.
Now i’m trying to print the file to a PDF file again so the rest of the people involved can view my work.
I’ve previously been able to print it this way without any problems, though with the exeption of the rendered objects in place in the building…
Does the 3d mesh objects prevent me from printing the files?
Or is there some option i’ve missed that could enable this option of export again…

Please do help!

  • I’m using Nitro Reader 3 for my printing option. Have previously tried just saving the file in a pdf but cant get that to work.
    Any suggestion to how i could do this differently??

I suppose one thing to try is to install a different PDF printer and try that.
Or post something that you can make to crash here for others to try with other PDF printers.

You say “seems to freeze and crash”. Could you be more specific? Is Rhino still visible but frozen? Does task manager show any CPU activity on either Rhino or Nitro? How long does it stay unresponsive?

181 Egå alle Tegninger Ventilation.3dm (15.0 MB)

This is the file i’m trying to print…
i dont even get into the printing options as it freezes as soon as i do ctrl-print

I’ve now printed this with both CutePDF and Nitro without running into any problems.
Does the same happen when you select all and run Export and save as a PDF? In my test here I see that Nitro creates the file but just as a test…

Anything written as error event ?
Please run command prompt WIN + R
On command prompt write eventvwr.exe and press ENTER
Search for errors in Event Viewer

tried exporting the file to pdf too… no luck… still freezing and not responding.
any idea whats gone wrong? using the new windows 10 operating system now btw… think thats the problem???
looking in the event viewer theres nothing that stands out besides the “normal” system fails

Since you wrote that this used to work but now no longer does, yes, there are good chances that that has something to do with it.

To narrow things down a bit - do you get the problem also when you run Rhino in safe mode? You’ll need to allow the RDK to load at startup to get the print dialog box.

Also, re-reading your original post again, can you print other files without problems or does the system freeze with any file?

Quickly responding, not sure if anyone else has said this yet but:

Much of my printing woes stem directly from one specific bug. The Print Spooler. Much of the time I find that if anything is failing to print, whether that means to PDF or to an actual printer, I can restart my print spooler and that will fix the problem 80% of the time.

Ctrl Panel
Admin Tools
Services

Scroll to Print Spooler and then hit restart in the upper left corner.

Don’t ask me why the print spooler starts acting up in the first place, its over my head.