PDF line weight became heavy after Rhino 6 update to SR17 (6.17.19189.16411, 8/07/2019)


Since the update to SR17 (6.17.19189.16411, 8/07/2019), I am now seeing thicker printed lines on some objects, as shown below.

Before the update:

After the update:


The thicker lines appear on Technical Details of Layout pages. I have not changed the Options settings.

The line weight problem occurs with RhinoPDF and PDFCreator, so it is probably an issue within Rhino.

I have attached the Print Width setting for Default, which is 0.0 mm.

The thicker lines appear to be shown for surfaces and polysurfaces. The lines for curves appear to be OK.

The page top margin is not being correctly set in the generated PDF file since the Rhino update.

The left and right margins have also been reduced, but not as significantly as the top margin.

I am now using Version 6 SR17 (6.17.19218.13231, 6/08/2019). It appears that the margins have been improved. Although they are not the same as in earlier release candidates, they are acceptable. However, the thicker lines are still appearing.

Regards, Garry.

Though I can’t answer why this is happening, I have always found that scaling line widths by 1.0 has always caused me problems. Under View and Output Scale of the Print Dialog, I find values between 0.25 and 0.4 give me the sort of result I’m looking for.

Hope that helps,


Hi Sash. I do not see those settings in the Print Dialog. I found a similar setting under Linetypes and Line Widths, which was set to 1.00. I changed the value to 0.25 and 0.35, but it had no impact on the output.

Under Rhino Options I found View Scaling Horizontal and Vertical settings, but they scale the overall image, not line widths.

Still puzzled.

Regards, Garry.

Hi Garry - are these in ‘Technical’ or ‘Pen’ mode? If so look in the display mode settings under Lines and adjust there - does that do anything?.


If possible, could you send us a model so we can try and repeat the issue?

I would also like to know if running the test command TestToggleTechDisplayMode and then printing gives you the thinner results you were expecting.

Hi Pascal. There are no helpful settings in that area. I have looked many times, but found nothing. All values are set to 1 pixel, which is the minimum allowed. That appears to relate to display rather than print. To clarify, the display on screen is correct, but the lines become thick on the printed output.

Regards, Garry.

Hi Steve. TestToggleTechDisplayMode did not help. I have attached a model. You will see that the lines on the display screen are correct, but some of the lines on the PDF are too thick. Look at the lines for L WM Dryer and L Double Tub.


HouseRemodelZReduced.pdf (1.3 MB)

HouseRemodelZReduced.3dm (4.0 MB)

Regards, Garry.

@pascal, can you check this out? I’m not sure if this is a stop-ship issue for 6.17 yet.

@stevebaer - I get the fat lines printing this file from 6.18. I’ll compare with earlier builds.

6.16 looks correct.
6.17 not…


I made it Major… adjust to taste.

@coffsoft thanks for the report.


Thanks Pascal, that makes this stop ship for releasing 6.17. I gave you the fun task of bisecting to find the exact build when things broke… sorry.

Hi Steve. There might be a clue to the build in my first post. I upgrade Release Candidates fairly regularly.

Regards, Garry.

Thanks Garry, we have multiple internal builds per day so hopefully we can find the exact one when the regression occurred

RH-54266 is fixed in the latest Service Release Candidate

Hi Brian. Thank you. I have installed Version 6 SR17 (6.17.19232.11391, 20/08/2019). That corrected the problem.

Thanks to @stevebaer and @pascal.

Regards, Garry.

1 Like