PBR Materials not working in Rhino 8 Beta

It seems to me that there may be two separate issues at work here. One is that there is something changing the color on pbr materials when they have an image set for the base color. @pascal you’ve covered this in

The second issue is that when I send the .rmtl files or a .3dm file with the .rmtls in it to a colleague, they are still getting poor results. They are either getting the pink colors or the textures aren’t showing. From what I now understand, it sounds like both of results might be caused by the embedded support images not getting read by the new computer. Once the images have been used once, (giving pink or non-textured results) then the second time they are used on any computer, the materials seem to find their embedded images again.

Could there be an issue with how the embedded images are getting unpacked the first time?
Can we get another look (and or bug report) for this second issue?

Hi Mike- is this true if you make a new material in the current build?


I noticed this too. I’m rendering things that have ral colors. the ral “traffic yellow” is a very clean yellow, though rendered with cycles wip 8 it leans more towards orange.

anyone knows how to compensate for this?

Hi Pascal,

I tried making the .rmtls from scratch in Rhino 8 (as opposed to opening the Rh7 .rmtl file and re-saving them) and so far so good! :+1: I’ve got more to make, but I’ll let you know if I run into any trouble with the rest of them.


Hi @pascal
I put together the rest of my .rmtl files and sent them to a 3rd colleague and we are still getting the hot pink look from the texture maps not loading.

I made all of these from scratch in Rhino 8. I can extract the supporting images from the .rmtl file and reconnect the links to the material and they work. But they are still not loading properly.

Here are a few examples:
18KY, Brushed.rmtl (912.2 KB)
18KY, Hammered.rmtl (1.3 MB)
18KY, Sandblasted.rmtl (7.7 MB)
18KY, Satin.rmtl (1.4 MB)

Hi @MikeM,

I took my original 4 ring image using your original materials and lost the orange cast:

Turns out that the default Rhino render settings in the Beta for Gamma and Linear Workflow are not the same as in R7. In the Beta they default to 1 and Off respectively. Change them to 2.2 (or as close as you can get given the intervals between values in the ropey slider control) and On and the cast goes.


1 Like

Are you sure? That’s not what I see. In the original V7 file posted, I saw gamma was set to 1 and linear workflow to off. The defaults should be gamma 2.2 / LW on

FYI these sliders can be double-clicked to set an exact value :slight_smile: