PBR Materials not working in Rhino 8 Beta

I created several pbr materials for Rhino 7 for different metal finishes. They were a great addition to Rhino 7 and look realistic to me.

However, some of these same materials are not working in Rhino 8 Beta.

The rhino files are too large to load on the forum, but here are versions with only one ring in the file and all of the render materials.
Rhino 7 - PBR single ring.3dm (14.8 MB)
Rhino 8 - PBR single ring.3dm (13.9 MB)

Here are the separate .rmtl files:
18KY, Polished.rmtl (53.7 KB)
18KY, Brushed.rmtl (924.6 KB)
18KY, Satin.rmtl (1.4 MB)
18KY, Sandblasted.rmtl (7.8 MB)

this is what I get with your Sandblast material

all default settings [I think]

it seems ok [Beta on Mac M2]

and this when the render is set to Bella [but renders in cycle raytraced… strange ]

Just a guess… I know that in Blender cycle, if a map is not found by a material, it shows as pink, so maybe its also in rhino cycle,

Hi Mike,

I had to reimport the Satin material into the model, otherwise all seems ok so far:

(On opening the model file there were satin material files missing.)


Thanks Jeremy and Akash. re-importing the .rmtl files fixes it here too.
It seems odd that the material doesn’t apply correctly when the file opens. :frowning:

The color on the satin and the sandblast finish appear considerably darker in Rh8 than Rh7 (see above for contrast). In Rhino 7, these .rmtl files all show the same base tone with different textures. Any idea why in Rhino 8 the satin and sandblast both look orange?

1 Like

I got the correct color for the sandblast when current render was set to rhino render.
when it was set to Bella, I got the dark shade like yours. [but both rendered with raytraced ]
Maybe try to play with this [you probably have other renders installed …?]

No idea why, But if you get the same results, then it’s a clue to the issue perhaps

Hi Akash,

I don’t have Bella, just Rhino Render and Legacy Rhino Render. I tried bouncing it back and forth between the two, but the Satin and Sandblast still look orange in Raytraced. They look normal in Rendered.



another guess… it might be a Window specific issue, since it renders correct on my Mac but @jeremy5 also got the dark color when he tested for you… Maybe time to tag a Dev.

Good idea Akash,

@nathanletwory, @pascal Any ideas what’s going on here? Or is there someone else better suited to answer this?

Hi Mike - I think we had some of the channels reversed at some point - I’ll take a look at your materials and see if I can figure it out - might still be there in some cases.

@MikeM there are textures missing for the Satin material.


the renderer was updated to cyclesX, right? when blender updates cycles, then changes in how light, materials, etc are calculated do happen. so I think to some degree we can expect some differences in the visual outcome. may or may not be related to this specific case though.

when you have the current renderer set to rhino render, you will see these options for gamma & linear workflow:


these will be applied to any viewport by default, regardless which renderer is set as current. We don’t want this for bella viewports, so the plugin initially sets the bella viewport display options like this:

with this done, rhino is free to do what it likes to other viewports, and bella is able to display its output as intended, so check & see if this helps explain what you are seeing

thanks @jdhill

the liner workflow is not [auto] set to custom here.

the fact that the setting [option] pages are so different between Window and Mac is not very great…

I will have to check it here, but you can set the values as I show

1 Like

Even stranger… I now get a white gold with your sandblast material

OK, so the links to the texture maps aren’t unpacking properly when I open the .3dm file? But they do unpack normally when I import the .rmtl file? Aren’t these images embedded in the .rmtl file?

Hi Mike - the textures are, optionally but by default, saved in the rmtl file.


Ok, so it looks like I need to re-save the materials in Rhino 8 and make sure that I am embedding the support files.

I tried that on this .rmtl file, closed Rhino, and deleted all of the unpacked temporary files from: C:\Users\mmagee\AppData\Local\McNeel\Rhinoceros\8.0\UnpackedFiles

When I re-opened Rhino, the material loads without any error messages.
So I think that’s one mystery solved. :+1:

Next mystery, why is this material weirdly orange?

Same material/lighting/environment in Rhino 7:

Yeah… rendered vs raytrace:

Looks to me like Cycles orangizes yellow in bitmap textures.If I use a ‘Single color texture’ of about the same hue, it looks correct. A single color image looks too orange.


I re-saved all the .rmtl files in Rhino 8, and now I’m getting better results. @pascal can you check these and see if it’s better for you too?

Rhino 8 Render Test.3dm (11.4 MB)
18KY, Polished.rmtl (53.7 KB)
18KY, Brushed RH8.rmtl (912.1 KB)
18KY, Satin RH8.rmtl (1.4 MB)
18KY, Sandblasted RH8.rmtl (7.7 MB)
18KY, Hammered RH8.rmtl (1.3 MB)

Scratch that… I tried the same materials on the ring file from before and it’s still orange.

The Satin and Sandblast materials are still coming out orange, but the Brushed and Hammered are not. That tracks with what you’re saying. Both Satin and Sandblast have an image for the base color, while Brushed and Hammered have a solid base color.

Hi Mike - here’s a bitmap that has about the color of your sandblasted texture - here this also goes orange in a material.




RH-77036 Cycles bitmap texture color