Rhino 8.8 crashing when create new PBR material from file

Hi guys,

I updated to the latest rhino 8.8 service release candidate yesterday. Now if i try to create a new PBR material from file, rhino crashes as soon as i open up the file explorer to find the material.

Im still able to create these materials by going through the “More Types” option and importing through there but not if i pick “Create Physically based material from texture file” option.

Has anyone else ran into this issue?

System Info:
Rhino 8 SR8 2024-5-16 (Rhino 8, 8.8.24137.03001, Git hash:master @ 827c456690f0d1d35b3df9321534fb35df1a5672)
License type: Educational, build 2024-05-16
License details: Stand-Alone

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Plus Graphics (Intel) Memory: 1GB, Driver date: 7-21-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port 1
Primary OpenGL: NVIDIA GeForce GTX 1660 Ti with Max-Q Design (NVidia) Memory: 6GB, Driver date: 3-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.76
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-1-2024
Driver Version: 31.0.15.5176
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24137.3001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24137.3001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24137.3001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24137.3001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24137.3001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24137.3001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Not yet, I will check on Monday latest

1 Like

Is this when importing an .rmtl file?

edit: I tried with both ZIP file from polyhaven.com and with an .rmtl, no crashing here.
edit2: I see my 8.8 install is 3 days newer. I don’t think I saw any changes go past related to this area of Rhino, but tomorrow there should be a new service release candidate for Rhino 8.8, try that and see if it works any better for you.

Yeah! i updated yesterday but hadn’t tried creating a new material through that path since. Just tried it a moment ago and its working perfectly!

Cheers Nathan, you have been a big help this past week or so!

1 Like