Patch problem


#1

I’m trying to patch a little area that gets removed during a chamfer. See photo 1. I tried using Patch but I can only select the curved line you see and not the actual edge on the left side - so the patch ends up not being completely filled. See photo 2. I have searched and tried a number of things but can’t figure out how to fill this little area in. It is not planar so Cap Planar Holes is ineffective.


#2

I ended up solving the problem by not joining the 2 solids (the top part and the bottom). I chamfered the top part and then Unioned it with the bottom. That did the trick but I’d still like to understand the issue above and how to rectify it.


(David Cockey) #3

Is that a real hole or a visual artifact hole due to the size of the display/render mesh? Rhino creates a mesh which is used for the display surfaces, extrusions, etc… The mesh faces have straight edges and do not conform exact to the edge curves. The size of the mesh faces is controlled by the mesh settings, and a finer mesh will be closer to an edge curve.

Try changing the render mesh settings. I don’t know how to do it in Rhino for Mac. In Rhino for Windows it can be changed in DocumentProperties in the Mesh settings.

You might also try EdgeSrf to create surfaces from 2, 3 or 4 edge curves.


(Pascal Golay) #4

Hi MIchael - I’d think about extending and re-trimming the surfaces all around the gap- hard to say from the images,but there may be a simpler solution than filling the hole with a new surface.

-Pascal


#5

Thanks guys.

@davidcockey - that was it! The setting is in File->Settings-> and I switched to Smooth & slower

@pascal - I tried doing that but it seemed to be more difficult than Patch. The surface was originally a cylinder that had been cut. When I Extend it, I could only extend the entire cylinder which necessitated re-cutting the part I needed. There may be other ways and I’ll continue to experiment but at least I learned a few new things.