Panes relocating when dragging between monitors


#1

We have one workstation here that is a laptop with 2 monitors (total of 3 displays). Running Win10.

When the user tries to drag a session of Rhino it immediately shrinks down to this tiny toolbar:

When he maximizes on another screen the docked layer and properties panes, which are normally stacked vertically, become unstacked and display side by side. Toolbars are locked.

I suspect the fact that Rhino as soon as it’s moved becomes that small toolbar is the source of the problem, but I’m not sure why that is happening. Odd thing is that it’s only Rhino. Everything else is fine.

Any suggestions?

Thanks,

Dan


(Pascal Golay) #2

Hi Dan - No good ideas off hand… but - I’d try restoring the Rhino window to a ‘reasonable’ size, maybe, then remaximize (assuming that is how it is) it and try the drag operation… any different? Does the unstacking happen if toolbars are not locked?

-Pascal


#3

Hi Pascal,

There are only 2 options. Maximized and that toolbar shown above. As soon as I try to drag a corner to resize the window it instantly converts to the image above. It does this whether toolbars are locked or not.

Did you have something specific in mind when you said “try restoring”?

Thanks,

Dan


(Pascal Golay) #4

Yeah - the restore button on the window controls if it is maximized - I’m just thinking that maybe the restored size is wacky - shot in the dark…

-Pascal


#5

That results in the same small toolbar. If I drag that little toolbar to the edge it will maximize. Once maximized I can use the minimize button to minimize to the taskbar. That works okay. Any other action creates that mini toolbar, and I think that’s what’s messing up the position of the panes.

It currently is impossible to drag Rhino (only Rhino) across his multiple monitors.

Dan


(Pascal Golay) #6

Hi Dan - try testResetWindowPositions

@DanBayn Another thing you can try is, in that weird state, if Rhino actually has focus and can accept a command, set the mainframe size explicitly - SetMainframeSize 1024 768
If Rhino cannot take a command it may work to add this to the startup commands while it’s normal looking then close and reopen.

-Pascal


#7

Hi Pascal,

I tried your first suggestion and it didn’t work. Then I recalled that I saved the registry setting from my computer that controls the global settings so I applied that. Problem solved.

I didn’t need to use your second suggestion.

Thanks for the help, and have a merry Christmas.

Dan


(Pascal Golay) #8

Phew. Thanks for the update; have a merry Christmas yourself…

-Pascal