Paneling Tools missing in Grasshopper

Hello guys,
I just installed panelingtools for Rhino 7 with the package manager and I have a tab in Rhino but the tab does not show in Grasshopper. I do get this error message though:

An error occured during GHA assembly loading:
Path: C:\Users\Tp\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.12.9.865\PTComponentLibrary.gha
Exception System.IO.FileNotFoundException:

this might help, worked for me

thanks for the quick reply. I’ve also installed it using package manager like in the linked post. The solution from the post was to update rhino but mine is already up to date…

yes, that is exactly what was happening to me
sorry for pointing this out if you have already checked that, the most important thing is to change the Rhino update settings to Service Release Candidates, not just Service Release
most updated version is 7.2.20343.11011 - 08/12/2020

did you try to install a previous version of Paneling Tools from the Package Manager drop list and had it loading succesfully?

1 Like

hey, inno
sorry if I came off rudely… I just wanted to point out what I’ve already tried so that people reading this post would know the context.
And this:" the most important thing is to change the Rhino update settings to Service Release Candidates , not just Service Release " was the solution.
Thanks alot! I did not know that you should switch it to Service Release Candidates from Service Release…

hope you and your close ones stay healthy and a happy new year!

all good, you were not rude at all!!!
:slight_smile: happy it worked!

Hi guys
I have a similar problem. Paneling tools Bar in Rhino7 works perfectly. In Grasshopper it doesn’t show up.

I already did what you discribed here: changing the update settings, but nothing changed.

There is an error message, it doesn’t contain specific words about paneling tools, but it complains about some Assembly loading which is not actived in this version of .NET Framework and that it couls be dangerous, because it leads to sandboxing??

It also says if you want to allow this you should activate the loadFromRemoteSources -button. I have absolutely no clue where to find this and it looks more like a line of code than an actual button…

Unfortunaly it is in german, but I’ll paste it here anyways.

Hope someone can help

Best regards

Exception System.NotSupportedException:

Message: Es wurde versucht, eine Assembly von einer Netzwerkadresse zu laden, was in früheren Versionen von .NET Framework zum Ausführen der Assembly als Sandkastenassembly geführt hätte. In dieser Version von .NET Framework wird die CAS-Richtlinie standardmäßig nicht aktiviert, dieser Ladevorgang kann daher gefährlich sein. Wenn Sie nicht beabsichtigen, durch diesen Ladevorgang eine Sandkastenassembly zu erstellen, aktivieren Sie den loadFromRemoteSources-Schalter. Weitere Informationen finden Sie unter “”.

Can you please get the latest service release (7.2) and let me know if you still have an issue?

Hi Rajaa,

Rhino updated today (actually to 7.3) and now the Paneling tools show up in Grasshopper too :heart:
Thank You.

Hi there, am unable to update Rhino service release at the moment. Can anyone help please ? Would really appreciate the help, thanks

I’m having a worse problem with paneling tools: neither Rhino nor grasshopper shows me the bar.

I’ve read some posts, but I’m still lost. I’m with the lasted version of Rhino (as shown in the picture). I used the package manager to install it and also tried to install it manually. Nothing seems to work =/


Hello @Pitanga_Vigand sorry for this late response to your issue. Maybe in the meantime your problem has solved, but if not, can you run _SystemInfo ad post back the results here?