Error loading - Paneling Tools

Hello,
After installing Paneling Tools in Package Manager, I get this error message opening Rhino.


My Rhino version is 7.2.21012.11001.
How can I resolve this error?

Which PanelingTools version do you have installed?
You can go to PluginManager, look for PanelingTools, and see the details. Make sure the “Enabled” Checkbox is on.
Perhaps also try to call the PackageManager again, and look for PanelingTools and make sure you are installing the latest version. Restart Rhino and see if it loads.

I believe I installed the latest version.


I’m not sure what “Enable” means. Do you mean the check mark right next to its version?
I re-installed it to see if it’ll fix the issue, but it didn’t work out.

Hi, I meant to check if that the loading of the plugin is enabled. This is how you check: run PluginManager command, and look for PanelingTools, there is a checkbox to indicate that Rhino should load it. See the image.
If it is checked, can you please let me know if this is the first time you install PT or your computer?

Thanks @rajaa. It’s been enabled. I had a previous version PT which I had no errors with. After I installed the latest version, I started getting this error message.

@Dongyeop_Lee can you try to download and install one version older of PanelingTools from the PackageManager and see if that loads correctly in your system?

I tried various versions in PackageManager, but it didn’t resolve the issue. I get the Rhino menu for Paneling Tools and Grasshopper components, and they seem to work. It’s just annoying to see this error message. I also don’t see Brick Pattern for pattern options of Panel 2D Grid…

Hi,
It looks like Rhino is loading an older version of PT and is prevented from loading the new one.
If you go to PanelingTools menu, and select “Help”, you will probably see an older version loaded. You can see the link to that older version (click “details” in the PT section of the PluginManager), and delete, then restart Rhino to allow loading the new version.

Alternatively, you can try the following:
1- Run the PluginManager and “unckeck” the “Enabled” box to force Rhino NOT to load PT.
2- Restart Rhino. PT should not load.
3- Run the PackageManager and download and install the latest PT.
4- Restart Rhino. If the new PanelingTools does not load, then open the PluginManager and check the “Enable” next to PanelingTools

Let me know how that works.
@will might be interested to address this glitch?

Thanks @rajaa, I have some ideas about how to prioritise plug-ins installed by the package manager. For now you’re right in suggesting that the existing plug-in needs to be removed before Rhino will load the one installed by the package manager.

Thanks so much @rajaa! Your alternative suggestion solved the issue.