Packing textures not always actually packing the textures

As the title says…is there anything known about this?

There are two ways Jim… clicking save textures in the save as dialog which just does it then (or should) and the Options>Rendering way which does it on every save.

Which method are you seeing it fail to embed with?

Hi Brian, it’s via the save dialog…it’s only supposed to pack them when you SaveAs? I have had it fail that way.

Or should pack them every time. Save or SaveAs, doesn’t matter.

Hi Jim,

I want to get the failure to embed logged as a bug if you’re seeing this. I will try to reproduce it but want to confirm the steps, is this what you did exactly?

  • Assign a new material (let me know the mat type pls.) to an object
  • Assign a texture to a specific channel (let me know which one) in the material
  • Run Save and check the box to “save textures”
  • On opening the 3dm on another machine, the texture is not unpacked into a folder in the same directory as the 3dm.

Hi Brian,

If I have a file that previously has packed textures, and add some more, then they don’t seem to get packed until and unless I reopen and resave the file.

Thanks for the extra info Jim… I’m still unable to repro here though. These were my steps:

  • assign a basic material with color map to objects
  • save and check “save textures” in the save dialog
  • close Rhino 5
  • open Rhino and the saved file… this unpacks the textures to a folder in the same directory as the 3dm.
  • assign a BAM with color and opacity maps to more objects
  • assign a BZ porcelain with color map to more objects
  • Run Save, the file size increases correctly.
  • Close Rhino and reopen the file

The unpacked texture folder only holds the first texture until the newly saved version is opened again. At that point the additional textures added in the BAM and porcelain are added to the folder.

If you have file that shows textures referenced but not added to the 3dm, please send it over… it may be due to some texture layering in advanced blends as a wild guess.

I’m not doing anything ‘fancy’ with textures, no. It also doesn’t happen all the time, but it’s just generally a mess. Just this morning I tried to open up a previous packed scene, copy something new into it, and save to a new folder, and…it can’t find all or most of the textures when I go to render. EDIT…And that’s not adding anything with textures to the file, geometry only, I go to render and it’s suddenly lost rack of files that were previously packed. The file size also seems to be ballooning.

Yuck… sorry this is frustrating Jim. The intermittence of the issue will make it hard to pinpoint what’s going wrong. If you have a test case that seems to cause this more often than not, please send it over. I will try again more myself as well to get a reproducible example for development to look into. Unfortunately, that’s the best bet at getting it improved.

Well I’m trying to zero in on what’s even actually going on…this morning it seems like, I wondered for a while if I was mistaken but apparently not…I open up my ‘scene’ with packed textures, copy and paste some geometry into it (which I suppose came from a file that itself has a packed texture or two, but not many) and suddenly most or all of the textures are ‘missing,’ and for some reason trying to see if it will render away results in a black render that is possibly hung.

I’m starting to wonder if it’s texture map specific like it’s file format or aspect ratio. Can you send me one of the textures that is missing from that file?

I am getting just about fed up with these texture issues. I’ve got a monster dual Xeon dedicated rendering box that I don’t actually use most of the time because the odds of everything actually opening up on it correctly are not great, whether the texture packing or unpacking doesn’t work or the materials get corrupted to Basic materials on saving, whatever. Just now I’m trying to deal with it ‘losing’ my scene HDR and refusing to open it even when I manually point it to it. And if I actually try to EDIT any of these files with packed stuff on the monster dual Xeon render unit, that’s just guaranteeing something is going to go to pot.

I hear ya… Pretty much every time I open my master file with 160 model robots on a different computer - which has a couple of hundred materials in it - I can be pretty much assured that a few of the materials have “lost” their textures, despite the fact that they are supposed to be “packed”… Since I switch back and forth between 3 different machines, this is downright painful. And the textures are not the only thing, but that’s another story…


I finally think I’ve narrowed down the culprit for a lot of these texture headaches is Linear Workflow, for me anyway. Could that be the case for you? Of course I never really got what Linear Workflow actually did, but after turning it off I unfortunately do now.


I had a similar issue with V-Ray and randomly lost texture maps. It happened even when both the 3D file and the textures were in the same folder. It was so intermittent, it drove me crazy. I finally discovered that the links were ‘broken’ when I opened the remote file on a local machine AND then later moved the folder to work on a local file on a local computer. It was the change (either direction) from session to session.

It took me months to communicate the error, but finally V-Ray investigated, duplicated the error, and just fixed it with an update. Maybe the moving is the cause of your issue as well. Hope you get it fixed!

Hi Brian.

I tried both ways… it worked once (honestly I don’t know what was different).

I save a rhino 5 file, check the save textures option and close the file afterwords . When I open it again, nothing happens. Even if I save again. What am I doing wrong?

Thank you for your help

i need some help here please.

Does RHINO save files with all textures in use?

Perhaps like E-TRANSMIT like autocad!!


Nope, you have to either click save textures in the save as dialog which will embed textures for that save of the file or enable the option to always embed support files. You could make this change in your template files too and then it would always happen.

Thanks for your answer.

But! ins`t suppose that rhino “transport” the files texture, for instance, from my external drive, into the folder which where Rhino is save?

If you embed textures into a 3dm they will be extracted when that 3dm is opened on another machine. At that time, they will go into a newly created folder in the same directory as the 3dm. Is this not working for you when transporting a 3dm file from one machine to another?