Package not compatible with Rhino Installer Engine

Hi all,

I’ve Rhino6 SR11 installed. I donwloaded and tried to install PT (2018121700).

When I double-click to the installer it show me this message :
“This package is not compatible with the Rhino Installer Engine. You may need to update to the latest Rhino Service Release to use this plug-in”.

I think I need at least the SR18.
So I tried to download and install the latest SR, by activating “Service Release Candidat” in the Rhino Options > Updates and Statistics window.
Rhino downloaded the SR25 (the last to date), but it doesn’t install. If I restart the software, it rest with SR11.

I don’t know what to do. Can someone explain this to me?

Thanks

Hi Davide - When you set the frequency to Service Release Candidates, Rhino will automatically download new versions when they become available. Have you closed all Rhino sessions and then launched Rhino again? When the download has completed, you should get a message that a new version is ready to be installed. Did you get to that point? If so, what happened after that?
-wim

Hi Wim,

I downloaded the 6.24 and 6.25 versions. I tried again but the plug-in doesn’t install.

So I downloaded the Repair file RhiFix, I launched that and it show me this log :

----- Summary -----
A fix was applied to your computer.
Version 6 (x64) of the Rhino Installer Engine will install packages for Rhino 6 and older.

RhiFix (3).exe version 6.0.6726.16913 starting…

------Details------

  • Detecting Rhino Installer Engine Executable … 6.24.20079.23341
  • Detecting Rhino.InstallerPackage registry key in HKLM … 6.24.20079.23341
  • Detecting .rhi registry key in HKLM … found.
  • Detecting Computed .rhi File Association … 6.24.20079.23341
  • Detecting User .rhi File Association (Windows 7) … not found.
  • Detecting User .rhi File Association (Windows 10) … not found.
  • Detecting 32-bit Rhino 5 … not found.
  • Detecting 64-bit Rhino 5 … 5.2.30328.21415
  • Detecting Rhino 6 … 6.24.20079.23341
  • Detecting Rhino 7 … not found.
  • Detecting File association mismatch … not found.
  • Fixing .rhi registry key in HKLM … succeeded.

----- Data -----

  • rhiexec_installed_version = 6.24.20079.23341
  • rhiexec_install_path = C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe
  • rhiexec_exists = True
  • rhiexec_platform = x64
  • rhi_system_registry_open_command = “C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe” “%1”
  • rhi_system_registry_open_command_path_exists = True
  • rhi_system_extension_registry_key_found = True
  • rhi_system_extension_registry_class = Rhino.InstallerPackage
  • rhi_file_association_exists = True
  • rhi_file_association = C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe
  • rhiexec_associated_version = 6.24.20079.23341
  • v5x64_version = 5.2.30328.21415
  • newest_rhino_version = 6.24.20079.23341
  • v5x64_install_path = c:\Program Files\Rhinoceros 5 (64-bit)\
  • v5x64_install_path_exists = True
  • v6_install_path = C:\Program Files\Rhino 6\
  • v6_version = 6.24.20079.23341
  • v6_install_path_exists = True

So, it can recognize the 6.24 version (the recommended version) but when I try to install the Paneling Tools plug-in, it’s still not compatible :

“this package is not compatible with the Rhino Installer Engine”

Hi,
I think the RhiExec that is still running is 6.11
You’ll need to run rhino repair installation. Please follow the steps and let us know:

  1. Open Programs and Features
  2. Select Rhinoceros from the list
  3. Click Modify
  4. Click Repair
  5. Follow the rest of the steps.

Hi Rajaa,

when I click on Modify, nothing happens…

I think I’ve a problem about permissions…

I activated all permissions to the *\AppData\Local\Temp directory, and now the Repair tool work.

Now Rhino is fixed. I launch PT installer, et I got the same problem.

Maybe I’ve to activate permission to others directories?

Can you please share the PanelingTools log file. You will find here: %appdata%\mcneel\rhinoceros\6.0\logs

PanelingTools2018121700 (2) (20200507-095927).rar (1.2 KB)

@davide.paba can you please send direct me to where you downloaded PanelingTools from? It appears to me that the correct (6.24) version of Rhino Installer Engine is running - and that it’s not able to detect the version information from PanelingTools correctly.

Food for rhino normally

It is fun. I’ve donwloaded “PANELINGTOOLS FOR RHINO AND GRASSHOPPER” from food4rhino, it been well installed.

However, I can not install “importe57.rhi” . It said " This package is not compatible with the Rhino Installer Engine"

Hi -

Which version of Rhino are you running?
-wim

Hi Wim,

I’m using Rhino 6 and Rhino 7 WIP

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501)
Rhino 7 SR0 2020-8-18 (Public Build, 7.0.20231.16005)

Hi - you shouldn’t be using the e57 import plug-in from food4rhino on these versions. Both Rhino 6 and 7 include an e57 importer out-of-the-box.

From the food4rhino page:

image

-wim

1 Like

Now I understand. Thanks a lot.
Bonne journée