RhinoPolyhedra plugin installation issue

Having trouble installing the RhinoPolyhedra plugin. The Rhino software is up to date, but getting the following error message when I try to install: “This package is not compatible with the Rhino Installer Engine. You may need to update to the latest Rhino Service Release to use this plugin.”
Also tried Control Panel > Programs and Features > Rhino 6 > Repair, and still getting the same error.

Hello - can you please run SystemInfo in Rhino and post(copy/paste) the results?


Sure - here it is:
Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Educational, build 2019-09-23
License details: Cloud Zoo. In use by: Richard Elaver ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: AD-212-LRTKPJH

Non-hybrid graphics.
Primary display and OpenGL: Intel® Iris® Graphics 540 (Intel) Memory: 1GB, Driver date: 10-11-2018 (M-D-Y). OpenGL Ver: 4.5.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build
Driver Date: 10-11-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Users\elaverra\Desktop\PROJECTS\GRASSHOPPER_S19\downloaded\elefront420\Elefront 4.2.0\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Are you trying to install the current Rhino for Windows V6 version of RhinoPolyhedra and not the V5 version? https://www.food4rhino.com/app/rhinopolyhedra

Yes. The file I downloaded and tried to install is rhinopolyhedra60686315197.rhi

That file installed for me in Version 6 SR19 (6.19.19267.15571, 9/24/2019)

I downloaded the file, opened File Explorer, opened Rhino, and dragged the file into a Rhino vieport. Then clicked on the appropriate permissions requests.
Closed Rhino, reopened Rhino and PolyHedron was available.

How are you trying to install it?

Hey @elaverra, I suspect that the file associations for .rhi are incorrectly pointing to the V5 Rhino Installer Engine. Please try running RhiFix.exe, as described in the first section here:


1 Like

Hi Will,
YES, that did it. Thank you!

  • Richard
1 Like