OSnap fails to snap, screen z-depth problem with meshes (?)

Hi all.
I’m reporting a bug that is happening somewhat “often” in the last months.
Latest Rhino 6 or 7 Beta, same problem.

In short: meshes prevent the clicking of osnap points.

See this gif.
Initially I am not able to snap on the quad point, if i’m not enough far from the object or look it from the convex side.
Then, a point that is on the surface (0 distance) have the same problem.
bug

Note that I’ve made the curve and surface purposely so the mesh have faces skipping the quad/point.
Here in detail with flat shade mode on:
2020-10-06 16_13_12-Untitled - Rhino BETA - Perspective
The mesh is a chord of the real surface, the point in this picture is actually is “behind” the mesh.


2020-10-06 16_13_22-Untitled - Rhino BETA - Perspective
Here the point is also on the edges of the mesh, so quad osnap and the point are detected correctly.

In this case, it was purposely made.
But working with mixed things it happens that i have to zoom inside a solid or switch to wireframe to snap on a point that is on the solid (0 distance).

Also, as seen on the gif, if a geometry is enough far, osnap works fine.
Maybe the screen z-depth have a tolerance % to distance?
If so, there is a temporary workaround, like increasing that tolerance? or to disable completely the z check and having osnap works on everything…

This sounds maybe like the typical side effect of having “Snap to occluded objects” unchecked in Modeling Aids.

1 Like

Thanks.
I didn’t know that option. Since when it exists? :sweat_smile:
I’d like to leave that off but for now i’m forced to use it.

I think since the release of V6… I agree it is useful, but has significant limitations.