Ortho snap in different views

Hi everyone, I’m working on a model at the moment that I need to set custom Cplanes for and am doing this using the 3point option. When I set the Cplane my orthographic snaps change along with it in the top view but in any elevation or perspective views the snaps seem to be set on an entirely different cplane. As you can imagine this is amaziingly frustrating because any drawing I do which I think is orthographic I have to check after everything I do. Does anyone know where I’m going wrong on this I feel like in plan view I’m snapping to my custom cplane but in any other I’m snapping to the world plane but I could be wrong about this. Also any time I select something in plan the gumball seems to also be aligned to what I think is the world cplane, if I change this to align to object then back to align to Cplane the gumball now aligns to my custom Cplane. If i can get this to custom cplane y default it’d be massively helpful. Any help would be really appreciated

Do you have Project active in the Osnap panel? If so, try deactivating it.

I haven’t got project on at the moment

OK… rereading - are you aware that setting a custom CPlane in one viewport does not assign it to the others?

If you are wanting to set a custom CPlane in the Top viewport and have the CPlanes in the other viewports automatically set relative to that - i.e. set a new synchronized local reference coordinate system in all viewports - you might also try setting Options>Modeling Aids>Universal construction planes.

thanl you for the suggestion I’ll try this at lunch

I wasn’t aware of this ( probably should have been before now), synchronize cplane is working well but has this also gotten rid of my world coordinate system?

Dont worry seems fine, thank you for the help