CPlane constantly changing

cplanes

#1

Hi everybody,

I use to work with Named CPlanes and lately I’m experiencing this issue. The thing is that when I’m working with the CPlane World Top (Assigned again and again with the rhino command icon for it), it constantly changes to another World Cplane that changes the Shift Snapping direction. So annoying, luckily.

Maybe I’m not “fixing” the CPlane at all after assign it or something?

Thank you!


#2

Do you by any chance have “Universal” CPlanes checked in Options>Modeling aids ? --Mitch


#3

Hi Mitch,

Standard CPlanes is the current checked option…
That’s how it should be if we are building our own CPlanes as well as the world ones, shouldn’t it?

Thank you


#4

OK, I don’t understand then why they would just change like that - once you set a CPlane in a particular viewport, it stays set until you reset it to something else… I assume you’re assigning the CPlane World Top to the Perspective view? So while you’re working in that view the CPlane changes to something else? That would be strange.

–Mitch


(Wim Dekeyser) #5

Is this in the regular Windows version (RH5) or the WIP?
You don’t have the AutoCPlane script installed?
Do you also have NamedViews?


#6

I’ve just found what I was missing…

I thought CPlane changing affects the whole file, not a particular viewport (Obviously it does so we project on Z axis into the parallel views… :dizzy_face:)

Combine that with working on a single maximized viewport and the _SetView icons (instead of four viewports and Ctr.+Tab as I used to) and the hidden grid also… It seems that when I came back to the perspective I was mantaining the previous view CPlane…

So… if it’s unavoidable to have a CPlane change when using the _SetView_World command, we have to combine _SetView_Cplane with parallel projection in order to preserve the assigned CPlane… not very usually I guess.

Anyway, thanks a lot for helping me to understand!


#7

It’s not… You can uncheck the following:

–Mitch


#8

Oh… good.
Thank you :slight_smile: