Orient perpendicular to curve - Rhino 5

Hi everyone,

I’m having problems using the tool “orient perpendicular to curve”. When I try to place the objects in the curve, they are positioned horizontally and not vertically, as the image I attached here (on the left: How it is / On the right: How it should be).
I am following a tutorial correctly and it works perfectly on Rhino 4, but when you follow exactly the same steps on Rhino 5, this problem happens. (A friend of mine who has Rhino 4 and Rhino 5 helped me following the same tutorial on the two Rhinos and confirmed this to me).

Does anyone have any idea what might be going on?

Thanks in advance,

Hi Tatiane- do this in the Front or Right view - which ever has the view through the ring and the CPlane parallel to the object to be oriented. The rectangle can be hard to orient to begin with in a way that the command likes - with the Perp option, I’d set it up as in this clip-


See also Flow, with the Rigid option - you’d make a linear array and map that from a line to the curvey curve .


Hi Pascal,

Thanks a lot for your help.
I’ve tried to do this in all viewports, and the result is the same. I just tried to use Flow, as you recommended, but it didn’t work, maybe because I’m not familiar with this tool.
I got a similar result with Polar Array, but I think it will not be convenient in all ocasions I need to have this result.
Honestly, I’d like so much to be able to use “orient perpendicular to curve”, because I’ll need to use this often. I don’t understand why in Rhino 5 it’s not possible to do that.


Hi Tatiane- notice the orientation of the object and the curve relative to the CPlane in the clip…


1 Like

Hi Pascal,

I’m having the exact same problem and the video is no longer available.
I tried to perform “orient perpendicular to curve” on front or right view and I don’t get the desired result (same as in Tatiane’s pictures).
Can you please upload the video again or explain in more details how to solve this issue?

Thanks a lot,

Hi everybody,
I encountered this also a numerous times. I tried all different viewports, orientations of the input object, etc. got really frustrated… till I found out that sometimes you don’t need the “perpendicular” option.
Next time you facing this problem try simply _OrientOncrv. It might do what you need.

gr, Tobias

Thanks Tobias,

I tried your solution and a funny thing happened, the orientation was OK but upside down i.e. the gemstone was on top of the ring and upside down. And if I clicked on “Perpendicular” the whole part changed its orientation again and won’t change back.

Any help would be appreciated.

Hi Guy - I don’t know what happened to the clip - it does seem to be gone - can you send your example file, I’ll see what I can do…


Chapter 6 - VolumeRing.3dm (310.3 KB)

Hi Guy - in this case, (I know it’s really kind of hard to sort out) the CPlane is not a useful one as the file opens so set that to Front. Then the Perpendicluar options plus 'Rotate does the job.


1 Like

Hi Pascal,

Thank you so much for solving this issue and for taking the time to make this video.

Thank you,