OrientOnCrv doesn’t perp my object to curve

running my button
OrientOnCrv requires object to be perp Cplane beforehand
sees profile not perp to curve.

code it runs is


I select curve at base point A and copy to the other locations but its not making them perp to curve to create a split pin at one end.

I try again selecting perpendicular in the options offered and now they are lying ‘dead’.
orientPerpToCrve.3dm (66.8 KB)


did you check the help for the command ?

the small videos explain the options

“default” x-axis of current c-plane and input object will match the tangent of the curve.
_perpendicular x-axis of current c-plane and input object will match the tangent of the curve.

is this, what you re after ? (green frame ?)
orientPerpToCrve_02_tp_rh5.3dm (106.9 KB)

Hi Tom,
yes thats what I am after.
The help videos declare an error on win 10. so dont run.

so what should I have done ?


see Text in file or screenshot above, i noted the options for the command.

maybe check the help from your mobile phone or another computer or get that fixed ?
(another browser might also help)

those little videos that ran in help tab worked with V5 in win7.
Now that I have win10 they error code me.
I use Chrome and also Firefox for the internet, but they are vids that ran within the help tab within V5 beside the work one is doing, and were great in that respect. win10 has broken it.

When I run a command they ran , so what should I do now to run them in that way ?

I am not using a piddly screen on a mobile to try and find them and run them, hate MB’s, I need to see them run as I choose the command. I dont have a second PC to place beside me and they wouldnt run on that in that clever way as command is typed in.


The help videos are just MP4 files so shouldn’t be a problem. What error message do you get?
Never mind, just reread your post and worked out you are referring to the Rhino 5 help ecosystem rather than your browsers.

I believe the R5 help pages used Shockwave which went EOL in 2019, so you are not going to be able to run these videos in the native help system any more. Instead you need to use a browser and access them online at Rhinoceros Help - What do you want to do? | Rhino 3-D modeling (mcneel.com)

check more infos about
and maybe also

google for “firefox not playing video”

this does not look like a rhino problem, more like a system / browser / extension / firewall issue.

this is the direct link to a video.

this might help to which video-file format the problem is related.