Opening a .dwg and saving it as .3dm drastically increases file size

Hello everyone.

I’m working on a project where the drafts are made in AutoCAD by a colleague and I have to make the 3d model. I opened the .dwg (AutoCAD 2007 format) in Rhino and saved the new file as a .3dm to use it for creating the model. I noticed that saving the file took a lot of time and the program would briefly show the message “Not Responding”. So, I checked the file sizes and it turns out the original 13MB .dwg was saved as a 110MB .3dm. I tried purging, then deleting a good chunk of the drawing, then purging again (all of this done in Rhino) but I only shaved off about a mere 3MB.

It’s not a procedure I haven’t gone through before. Typically, the resulting .3dm has pretty much the same file size as the .dwg.

Any ideas what is going on? And hopefully, any way to reduce the file size?

Hi @kotsospapado
There’s probably some plug-in involved. Would you happen to have eg. V-ray or Enscape installed? You can try SaveSmall (or save the file without plugin data) to see if it makes any difference.
HTH, Jakob

I deal with this alot and the first thing to try is to just selall and then do a join. There are thousands of poly lines that get broken up into individual segments or arcs when importing into Rhino. Watch the command line when you hit Join and it will tell you how many curves are being joined and report the final result. Save and check your file size afterward. Sometimes it is best to sel all curves and lines by layer and then do the join.

That’s normal, it always been.

Hey everyone. Thanks for the replies.
Jakob, there might actually be some plug in involved, but from AutoCAD. My colleague uses a plug in that produces door, window and furniture blocks. That might be an issue.
I tried copying all the objects (Ctrl+A) from the huge .3dm to a whole new .3dm. After saving the new file, the new file size was reduced to 13MB, like the original .dwg. I can’t tell what happened there, but it sure worked.

1 Like