Open edges after SubD tu Nurbs command

Hi all,
I am a beginner with subD. After modeling a SubD with Sweep1 command and editing, I transformed it into a Nurbs with SudD to Nurbs. An open edge appears, and the join edges command doesn’t work.
I tried to limit the wrong side and copy the good side. After that, the open edge is located in the middle on the top. Somebody can help me please?

Help with a question such as this one is more likely if a .3dm file with the before and after geometry is posted. A file can be included in a post by dragging the file to where the text of a post is typed, or by clicking on the vertical arrow icon above where text is typed.

1 Like

Here is the file, David.

Open edges after SubD to Nurbs.3dm (325.9 KB)

The only naked edges I see are along the inner sides of the surface. I do not see a naked edge where the two edges meet. I ran ToNurbs and the result was the same.

Big Mystery!
I tried again and where you have a fatter UV curve, I get an open edge again. Could this be related to the options in the order? Could this be related to the options in the order?
Or is it related to a bug in my version of Rhino?
Have you any suggestions what I could do?

Hello - your subD has naked edges - do you see nakeds other than the ones on the original when you ToNurbs it? Use Bridge on the SubD to close it up.


Hi Pascal,
The naked edge is not visible for me on the SubD, it arrives during the command to Nurbs. I enclose a video, where you can see me doing it.

I tried something else. I closed my SubD with bridge command to get a closed ring, like you did. Then I did To Nurbs and ended up with two open edges.


Hello - is ShowEdges set to show all edges or only naked ones? What does the command line say when you run ShowEdges on the Nurbs object?


The image I posted was of your NURBS surface without any modifications. Strange that you see naked edges and I don’t. I’m using Version 7 SR5 (7.5.21096.11001, 2021-04-06)

It looks like you used _Sweep1 instead of _SubDSweep1

Below is what I get with _SubDSweep1

show edges is set to show all edges.

When I run the show edges command on the open Nurbs objet, the command line says : 3 edges found, 2 free edges no manifold edge.

When I run show edges on the Nurbs object on which the bridge command has been done before on the subD, the command line says: 2 edges found, no free, no manifold. But you see the 2 pink lines as on the last picture I sent you.

After that I tried to make a booleen difference on this object , which is supposed to have no free edges, but which has the pink lines, just to see what happens and see what I got:


I used subDsweep

Dear Martin,

You are probably right.
When you use subDsweep, with my curves, it looks nice.

And when I do it, it looks like this:

No clue how you manage to create this self intersection?

Hello - please see Help on ShowEdges - if it is set to ‘All edges’ it will show you all edges regardless of whether they are naked or not. If you want to display naked edges, set the control to show naked edges and not all edges.


Thank you all for taking the time to help me. I was able to finish my object now .

1 Like