Open dwg files but nothing linked or embedded

I have been having issues opening or importing dwg files into my Rhino 7. When I open or import dwg files in Rhino 7, the Rhino file opens entirely empty (I did select all but nothing is selected). When I open block manager, it says the blocks are not linked.

I do not understand why this is happening and had this happening to me all of a sudden one day and ever since. I tried uninstall and reinstalled Rhino 7 but no luck.

Any help would be appreciated!

If the blocks use Xrefs, the message may mean that it is looking for additional file(s).
However, there are no file names listed under “Link File Name”

Do you know what the AutoCAD version is … or, even better, can you share the AutoCAD file?

Hi Boer -

That’s because they are embedded.

What happens when you Insert “Block_1” or “Block_3”?

Yeah, I have tried CAD versions 2010 to 2018. No luck. When I open the files in CAD all geometry shows up and without xrefs. This always happens when the CAD files have blocks within them.

Yeah, if I insert the blocks the geometry will show up. But I have multiple CAD blocks coming in at different heights. i dont want to have to re-insert 20-30 cads into Rhino one by one.

Hi -
Please post a dwg file that is behaving like this.

@Boer_Deng -
I’ve added this thread to RH-72439 Open DWG: incorrect blocks in Rhino
It would still be great if you could post a file.

RH-72439 is fixed in Rhino 7 Service Release 29 Release Candidate