One of my favorite V-Ray tricks - coloring a material


one of my favorite tricks to change the color of materials is to add a black emissive layer with a colored transparency. Here an example. I rendered a watch in silver metal and my client want to see a golden version. I would need to add a golden color to reflection map and the diffuse map. But quicker is to add an emissive layer with golden colored transparency on the top of the material. (In the texture slot I add a simple white color and per simple enable/disable I can switch between the golden and silver version.)



Not sure this is physically correct but if works…NICE TRICK!
Thanks for sharing.

The 3D model need a bit of SoftenEdge btw. :stuck_out_tongue:

SoftenEdge … right, I checked it and found that “same object only” was enabled to avoid a rounding between different objects. I disabled it for a test and the chamfer looks much better. Perfect would be not to use split objects for different materials and to use subselection materials. But it’s difficult to setup, if dozen of surfaces needs to be controlled. I wished I could join the surfaces after the setup and mapping/materials would kept.

Physically correct? Good point. This brings me to an annoying thing. V-Ray is overcorrect. You can’t mix up a colored diffuse color with the same color at the reflection slot without to get a strange tint. Here an example - orange colored texture in both slots cause a greenish addition. Very annoying. I used my workaround since such a long time that I forget that this was the reason to find a way to get colored metals without the particular color shift,

@Nikolay Is there a way to disable the “physical correctness”? If not, could an option be added please?

The whole point of the renderer is to be as much physically correct as possible

But the physical correct result looks wrong, my clients want to get it. I never have seen an anodized aluminum with a tint of the complementary color. Only if I use a workaround based on independent material layers I get what I expect. Is there no way to disable this strange looking correctness? Can you show me a photo where the strange color effect can be seen at the real world?

Hi guys,

The Emissive layer trick is not something I was familiar with and is not something I’d recommend.
However it seems to do the trick and preserve the ‘physical accuracy’.

As an alternative I would suggest you use an instance of a Color map passed through a color correction and corrected accordingly for both slots. This way the source color can be changed easily:

As for the energy preservation:
V-Ray is doing it’s best to avoid situations in which more light is reflected by the surface than the light hitting it.
There are two ways in which this can be gone in V-Ray:
R, G, B - in this mode the three channels are equalized separately and hue changes might come as a result
H, S, V - In this mode only the value is clamped while the hue and saturation are preserved.



Unfortunately the RGB mode is always used in Rhino and you can’t change that unless you use a script. This was done because the GPU engine does not support the monochromatic mode.


Thank you for your advice. So far I see that we have two different types of conservation of energy with two different results. But only one can be physically correct. :wink:

From my daily experience, I don’t remember seeing a hue shift (RGB method) in the real world. This makes the rendering work difficult.

Couldn’t you ask the core team to skip this method and implement the monochromatic correction for the GPU as well? I always work in GPU mode and the hue shift is frustrating. Why should we bother with strange colour shifts for years to come? A solution is needed. :wink:

I agree!
Less correct but more usable.