Oh no - cloud licence problem

I closed Rhino V6 on my iMac and tried to open V6 on my MacBook - and I get the beach ball (with doesn’t show up in this screen capture)…

I’m sorry, but this should NEVER happen!


Luckily I can open Rhino on my iMac. Yesterday this would have been a catastrophe - I was traveling (with my laptop) and had an important presentation.
Is there anything I can do if Rhino gives me the beach ball and freezes?


Sorry, I don’t understand.
When you share a single license between multiple computers in a Personal license list, then when you start Rhino and get a license, the other system that was using the license gets the question.

Also, there might be another dialog hiding behind everything that needs to be answered.

If you were traveling and had not started Rhino before leaving, it’s possible the previous two-week license lease was expired.

It’s a good idea to open Preferences > Licenses and see when your off-line use expires. It should normally be a couple weeks in the future.

Perhaps my explanation wasn’t that great… I’ll try to explain again. I usually work on my iMac - also tonight a was working on a project and also found the transparency bug we already discussed. I then closed Rhino on my iMac and wanted to check if I’d get the same bug on my MacBook. Trying to open Rhino WIP on my MacBook resulted in the freezing splash screen and licensing box. I had to force quit to dismiss the splash screen and licensing box. There was no other dialog box hiding behind those (I checked). I then tried to open Rhino WIP on my iMac again and that worked normally - fortunately.

The result is that I can use Rhino on my iMac - but still not on my MacBook (I just get the freezing splash screen). Are you sure there isn’t a problem with your licence sever?

I did that yesterday just to be sure, but I might forget that some day. Rhino still needs to be 100 % foolproof. I really can’t afford not having Rhino working…

It probably is a good idea, but too easy to forget when you’re in a hurry.


The 100% foolproof option is expensive.
It requires separate stand-alone licenses for each computer you need to run Rhino on.
And that does not account for operating system and hardware issues.

This is our first attempt at this Internet floating license tool.
I’m personally quite impressed with how it works and how responsive @aj1 has been with understanding and fixing issues.

Additionally, use of the V6 Mac WIP should not be included in your “100% club” either.

I know. I just wanted to report this so you could - if possible - further improve the system and make V6 as “foolproof” as V5 was/is.
I still can’t open V6 on my MacBook, so something is obviously wrong here.


On your MacBook, go to the Rhino Web page:
Click on the “my account” or “sign in” link
Make sure you can see your licenses in your Personal licenses list

You might try Logging out and back in too.

Does any of that get you going?

For some reason I was signed out. I logged in - and out - a couple of times, but still no go. Rhino WIP refuses to start on my MacBook.

I checked the licence on my iMac and I should have “offline access until: 11/01/2018…”


Your iMac is doing what it should.
Is it possible you are signed in to a second Rhino account on the MacBook that has no license?
Go to the licenses web site on both systems and verity you can see the license in your Personal list.

Also, is it possible there are multiple Rhino WIPs on that system?
The “TestFindAllRhinoApps” is helpful for ferreting them out.

Nope, that shouldn’t be possible.

I did.

I can (“There is 1 valid license with one seat.”)
I think I’m confused… :thinking:

Edit: It’s late here. I’ll try again tomorrow.


Okay, then we can rule out the fairly common multiple rhino account problem.

How about multiple old Rhinos?

That shouldn’t be possible either. Both computers are new (bought in May and August). I have Rhino 5.5.2 and V6 WIP on both.



This looks like a bug on the Mac at first glance.

Before we continue, I will warn you: Rhino 6 for Mac WIP is in its infancy, and has only been tested outside of McNeel for a few weeks. As of this writing, please do not depend on it for mission critical tasks–at least not without a good backup plan.

It would be helpful if you could PM me the following file:
~/Library/Application Support/McNeel/Rhinoceros/6.0/License Manager/Licenses/cloudzoo.txt

Then, go ahead and delete this file and try starting Rhino again. You should be prompted to login again since the file was deleted.



I know V6 is a WIP and I’m exporting the files from V6 to V5 as backup. It’s hard not to use ‘real’ working files for testing. We have waited a long time for V6 and now I’m eager to use it. I don’t think I have time and patience to just ‘test’ V6 or ‘play’ with some unrealistic testfiles - I like to combine testing and working - and I guess I don’t have any non-mission critical files, so I’m taking a deliberate risk, of course. Getting actual work done with V6 is the best type of testing - and learning the new features in the process. That way you also get realistic feedback from users testing real files. It’s a win-win situation most of the time. I haven’t lost any critical material testing Rhino WIPs since 1997, so I guess I trust you guys :wink:

I’ll send you the file and follow your instructions to get Rhino working on my MacBook again. I’ll let you know how it goes.

Thank you both, John and AJ, for your help!


Deleting the lic-file and restarting Rhino V6 on my MacBook helped. Now it’s working again.


Hi @Philip I’m very glad it works now. I will investigate the files you sent me to see if I can reproduce the problem on my end.

I agree 100% with what you said, and it is from users like you that we benefit the most from by pushing the WIP to its limits (Otherwise we wouldn’t find any bugs to fix!). The only thing I wanted to note is to make sure there’s a backup plan in case the WIP does not behave as expected, which may happen often in the next few months as we fix the most critical bugs.

Have a good weekend!


1 Like