OffsetSrf is messing my geometry


Hi, I have a problem with the OffsetSrf when the solid is turned on. When I try to offset surface with rounded corners it connects all the “edge” surfaces to one. The result surface is terrible and it’s really hard to edit afterwards… On the flat surface, the result should be the same as extrudeSrf, but it isn’t.

It botherd me in V5, but i hoped, it’ll be fixed by now (in V8).

1 Like

It typically happens when I have sheet metal part like this, and I want to add a thickness to it:

1 Like

I do agree, but its doubtful that anybody at McNeel cares.

What you need to do to fix it is run the command DivideAlongCreases with options set to SplitAtTangents=Yes SplitAtKinks=Yes


Snide comments above notwithstanding, this is indeed a known and open item on our bug tracker - I have added your comments. I do not have any idea how near the top of the pile it is however - DivideAlongCreases for now…


1 Like

I take it you are trying to claim someone at McNeel does care?
That claim isn’t very convincing given that this easy to fix bug has been lingering in Rhino since at least Rhino5.