"offset Curve on Surface" Rhino 7 crash

i have a new machine at work and since then, when i use the command “Offset Curve on surface” it freezes and when i press cancel an instability Alert shows up (Rhino unsafely canceled the command you were running…)

IT installed various Rhino 7 versions and always the same crash happens.

Is it a hardware problem?

1 Like

Run the Rhino command SystemInfo and post the results here.

Torsten is currently using Rhino 7.16 which has been cleanly removed and re-installed today.
He accesses his desktop remotely from home via RDP remote desktop connection - could this be the reason?

We will add the systeminfo asap.

Hi Richard -

Yes, RDP is not supported - Rhino - System Requirements


I doubt it comes from the Tomate desktop as it worked fine before.

Anyway, here the systeminfo:

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)

License type: Commercial, build 2022-03-08

License details: LAN Zoo Network Node

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP (Hosting Remote Desktop session)

Standard graphics configuration.

Primary display: Microsoft Remote Display Adapter (Microsoft) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).

Remote Desktop display device with 16 connection(s)

  • Windows Main Display using connection #0

Primary OpenGL: NVIDIA RTX A4000 (NVidia) Memory: 16GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65

Accelerated graphics device with 0 adapter port(s)

  • There are no monitors attached to this device!

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: None

Mip Map Filtering: Linear

Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 1-28-2022

Driver Version:

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino

C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino

C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001

C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001

C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001

C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001

C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001

C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Just a guess. Try disabling V-Ray and restarting Rhino. V-Ray caused a seemingly unconnected problem a while back.


Disabling Vray was the solution.

Thank you,

Topic closed