Rhino 7 not displaying surface edges, curves, crashes PC


My Rhino 7 is having a critical issue which basically makes it useless in it’s current state. I’ve had this issue for a few months now and I tried updating drivers as well as reinstalling rhino 7 but to no avail. Any help would be much appreciated.

The issue:

  • Opening existing files with curves / geometry, it’s clear that it looks off, as loads of curves/geometry appears to be missing. Not long (roughly 30 seconds) after opening a file with existing geometry/curves, rhino freezes and so does my computer, and the only way out is a hard reboot. I have tried with multiple files, some that only have curves in them.
  • Opening a clean file, the program stays open, but when trying to draw fresh curves, nothing appears/is displayed. When drawing geometry, like a simply box command extrusions, the surfaces themselves appear, but the surface edges do not, and as such it appears “naked” and the only indication that one has selected the box is the gumball (image1).

In the image below I have selected a retangular curve. The curve itself is not displaying but the gumball and control points are, confirming that the curve is indeed there, but not displayed.

System info:

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commercial, build 2023-02-27
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Radeon RX 570 Series (AMD) Memory: 4GB, Driver date: 3-15-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 3-15-2023
Driver Version: 31.0.14043.1000
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 11994 MB

Rhino plugins that do not ship with Rhino
C:\Users\Chris\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21250.810
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Graphics drivers:

Thank you!

Hello - in Options > View > OpenGL page, move the OpenGL slider one notch to the left - does that sort anything out?


It appears it did the trick! All geometry is displayed now and my computer hasn’t crashed (yet).
Can you explaing what the reason is? Is my hardware simply too outdated to have max opengl settings?


I would also try unchecking “gpu tesselation” in Options > View > OpenGL, and see if you can move the OpenGL slider back up.

The current crop of AMD drivers have some issues…

Thank you! I suspected the AMD drivers to be the issue but couldn’t be sure as I don’t have issues with games/other software.

AMD card hardware seem fine. They don’t have as good a record with drivers as Nvidia.