Objects with edgesoftening won't update positions in rendering

After updating to latest rhino 8 and vray 6. If i move objects and they have blocks in same group, positions of simple objects don’t update when rendering. Need to save close file than open and only then they render in proper locations.

hi @tomas3 can you share a (simple) example file with clear instructions how to repeat the issue? I can then see if this is a Rhino or Vray issue.
Too large and or confidential files can also be sent here

Hello, uploaded (Sample_file.3dm) to tech@mcneel.com
Just move all elements and only blocks will update location in render. If you save close and open file than all elements will render properly. At least this is my experience.

@tomas3 thanks for the file. I cannot repeat the issue you are describing.
I selected all objects, and moved them, they’re all moved in the V-Ray rendering as well.

Can you run _SystemInfo in Rhino and post back the results and also Vray > Help > About?

Hello, here is rhino info:
Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\NamedPositions.rhp “Named Position”

And vray:

Updated drivers clean installed both programs, but same result. This happens with all old files that have blocks.

Vray log shows no errors too.

Did more experiments:
Exploaded all blocks and deleted them from file. Objects still don’t update in rendering when moved, BUT if i rotate object it updates its location.
Create mesh from polysurface it also doesn’t update in render. Any new object created in same file works fine.
Copied polysurface from original file and has same problem so its not blocks problem.

Figured out it’s edge softening if i turn it off everything works. Any ideas why this happening?

hi @tomas3 I’ll update my V-Ray to the latest and see if I can reproduce.

@tomas3 thanks,

@Nikolay I can confirm this bug in the latest V-Ray for Rhino. Objects with EdgeSoftening enabled stay in their original place in the rendering.

To reproduce, download the attached file, render the perspective view, then move the two cubes and notice the one with edgeSoftening does not move in the rendering:

edgesoftening_vray6.20.03.3dm (96.7 KB)

QA confirmed it already. I’ll check it out after the holidays (it is Easter this week here)

thanks @Nikolay

Everyone here is on Rhino 8.6 and it is broken there,
I’m only on 8.5 and it is working for me:

Something did change in SP6, and it either needs hooking up in V-Ray or a revert in Rhino

@Nikolay, thanks, maybe @andy can comment on that. btw: When I tested in previous Vray 6, I could not reproduce the issue. But I do see a (solved) YT’ related to edge softening and their position in Raytracing as well.

Ok, so it is CRM2, as I expected. Prior 8.6 the transformation was baked in the mesh itself, now the mesh stays the same, and the transformation is delivered separately.
I fixed it on the V-Ray side already, but we will require 8.6 in the next release, to be on the safe side.

@tomas3 you either downgrade to 8.5 or wait for us to roll a new release.

Hello, thanks for info same problem with “thickening”. And when you planning to have new release?

all modifiers deliver the render mesh thru CRM2 - shut linting, displacement, edge softening…etc.
the release plannig is not up to me, but they are usually a 2-3 months apart