Objects not displaying properly, especially with clipping plane

I’m having problems with certain objects displaying correctly in 3D in Rhino 7. They seem to be ok in Wireframe, but in Shaded, Ghosted, or even Rendered mode Rhino fails to color inside the lines. In Rendered there are even shadows where there shouldn’t be. I’ve been using Rhino for 4 years and this is the first time this problem has been this bad for me. It’s to the point where I can’t tell if parts are mating properly, although they appear to be in Wireframe mode in the Right viewport.

These are just extrusions, but at one point I boolean subtracted one from the other and merged all faces.

The last pic shows a sample assembly that I had made in the same file before making the larger assembly, and the sample displayed with no issue, so I think it may be a problem with the objects themselves.

Here are some things I’ve tried already:
ClearAllMeshes
RefreshShade
SelectBadObjects (there were none)
Exploding then SelectBadObjects (still none)
ExtractBadSrf
Checked that viewport resolution sharpness is set to Pixel Perfect and responsiveness is set to slowest
Tried moving geometry closer to origin (this was recommended in other threads on here)

System Info:
Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Commercial, build 2022-05-04
License details: LAN Zoo Network Node

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro M2000M (NVidia) Memory: 4GB, Driver date: 6-22-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 513.29
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
Intel(R) HD Graphics P530 (Intel) Memory: 1GB, Driver date: 1-21-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-22-2022
Driver Version: 30.0.15.1329
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\user\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”





Here’s an interesting development. I decided to retrace my steps making the extrusions and this is what happened.

  1. Pulled up the designer’s original 3D model, which was just closed solids rather than the assemblies you see in the previous post. From these I duplicated the face borders.
  2. Used SelPlanarCrv to check that they were all planar. One of them wasn’t! That might explain why the extrusion are bad, but maybe not. See following steps.
  3. Exploded the designer model
  4. Used SelPlanarSrf to see if the surface whose border I duplicated was planar. It was. What does this mean? How could a surface be planar if its borders aren’t?
  5. ProjectToCplane the curves so they would be flattened out, then extruded them. They still displayed poorly.
  6. Checked for self-intersections and found none.
  7. Used Cylinder to create, well, a cylinder with a diameter roughly the size of the original part and thickness similar to the original. This also displayed poorly around the edges. So is it just an issue with displaying large objects?

Back to the drawing board I guess.

Hi Jake -

It would help if you could upload a simple 3dm file, but it sounds like you need to take a look at the Document Properties -> Mesh settings.

Apart from that, …

… we’re on 7.26 at the moment.
-wim

Thanks for the reply. I just checked the mesh settings and it was set to Smoother and Slower. I tried changing it to custom and turned it all the way up using the Simple slider control, but this didn’t help unfortunately even after running ClearAllMeshes again.

As far as the software version, I could try updating but I have to go through my company’s IT department so I’m saving that for last.

Hi Jake -

In that case, we’d need a 3dm file to be able to see what’s going on here.
-wim

got the same card (EDIT, not exactly the same, but Quadro and 4GB, I think like a Quadro K2200) and since rhino 7 I needed to go to Options-View-openGL and uncheck GPU Tessellation. Otherwise I couldn’t work at all. afterwards it works waay better.
I guess the our cards are too old.

Hope that helps.

B

That didn’t do it for me. Thanks for the suggestion though.

Hi Wim. See below. Thanks.

Display issue.3dm (4.6 MB)

Hi Jake -
You’ll have to play with the settings in the custom meshing dialog. In a quick test, these seem to play nicer with your model:
image

Also take a look at the help file for information on those settings.
-wim

That was it! After reading through the help file I found that I actually only needed to change the Maximum distance. I wouldn’t have thought that would also affect the clipping plane intersection lines but those are fixed as well.

Thanks again!

EDIT: For anyone who might read this in the future, I’m finding that this does affect performance on my older machine. There’s a little bit of a buffer time when I zoom/rotate or turn a lot of layers on, so for that reason I’ll only really use this setting to check part interactions intermittently. The problem as a whole only seems to occur on large round parts which I guess is because the shader mesh is calculated based on part size.