Clipping plane produces a mess of lines

Hi All,

When I create a clipping plane I get a mess of lines, could anyone explain why this is.

Only seems to happen with certain kinds of objects. Simple extruded shapes and solids are exempt, but lofted objects and objects imported as stp files from Solidworks get the treatment. No doubt this is simply solved, but I can’t (yet) find any reference to this problem in this forum.

Wow… can you post a file that shows this, and, run the SystemInfo command in Rhino and post the results here?



Hi Pascal,

Thanks for getting back to me so fast. Test clipping planes.3dm (854.7 KB)

I hope the sysinfo file as a png is ok?

apologies, just read your instructions properly now, here’s the sysinfo file run from within Rhino…Phild.txt (2.2 KB)

Hello - thanks - I don’t know if it will matter, I’d be surprised, but please disable VRay in Options > Plug-ins, then close and re-start Rhino - does that change anything?

Also, SectionTools, just in case…

Hi Pascal,

Seems to have reduced the mess but not entirely done away with it

Perhaps a repair on Rhino?

Hello - are your display modes set to default? If not, can you try with a default shaded mode?


Hi, restored defaults on display modes, but it hasn’t made any difference. Would the fact that none of my default settings files are available, on startup, have any bearing on the problem?

By this do you mean template files? I would not think that matters for this but it is unexpected that they are not there - try running a ‘repair’ on the Rhino installation in the Windows control panel.


Hi Pascal, yes, template files. I tried a repair and restart, but no luck

Is there any significance in the fact that this does not happen to simpler shapes?

@trytroy - a shot in the dark but try disabling ‘GPU tessellation’ in Options > View > OpenGL page…


Hi Pascal, that did it, but in reverse because the GPU tessellation was off. Enabling it took away the problem.

Many thanks!

Hm - I wonder why it was off - we’d talked about disabling GPU tessellation on some cards that are known to have problems with it but I don’t know if we are doing that automatically now and your card is on the suspect list for some reason.


It’s possible I switched it off in an attempt to solve another problem (black screen) then forgot to switch it on again. Can’t rightly remember.