Clipping Plane display problem

Hi all,

I ran into a weird Clipping plane display problem while trying to set up some Layouts for plans and sections. As soon as I copied a Layout and tried to change the Clipping Plane position/orientation (i.e. to make a new section view) things went haywire with the display (see attached images). Also, the model view is affected in Shaded mode (the magenta bleeding is because I set it as a backface display color in Shaded mode), but weirdly not in Rendered mode.

I am also attaching the Rhino file and the result of my System Info. The geometry inside the file usually doesn’t cause any of those display errors (it’s just closed mesh boxes). After opening the attached file, the display error seems to persist (same weird display you see in the attached images) if I try to open a new file and use a Clipping Plane on newly created geometry (for example, a simple array of spaced Mesh boxes).

I already tried (without effect):

. disabling GPU tessellation
. restarting Windows

Any idea about what causes this behavior?

SysInfo.txt (2.8 KB)
Clipping Layout example.3dm (1.4 MB)

This happens also with simpler geometries, like this array of boxes. As soon as I set up a couple of layouts and set clipping planes to be active in one layout but not the other, the problem appears.

Here’s the Rhino file (new reply due to the 5-attachment limit)

NewGeometry.3dm (4.1 MB)

Hi Alessio -
Here, on Rhino 7, I’m not seeing anything wrong with that “NewGeometry.3dm” file but am seeing the issue with the “Clipping Layout example.3dm” file:

Much of the display code has been heavily modified in Rhino 8 and this appears fixed here:


As a matter of fact, if I close Rhino and re-open it, New Geometries looks fine on my side too. But the display was fine as well when I created the geometry and the clipping planes in the model. The issue appeared when I started assigning clipping planes to different layout views.

From your words, I assume there won’t be a fix for this issue in Rhino 7…