Objects are missing cut edges when clipped outside visible area


#1

As you can see in the image below, the first box was cut by the clipping plane while it was visible in the viewport, wile the second one, which is missing the edges, was out of the view when the clipping plane cut it. Once I move the camera and I bring it into view I have to set the display mode to shaded again for the edges to show up.
It would be very useful to have the edges show up automatically.


(Pascal Golay) #2

Hi Bogdan-
That is how it should work - and how it works here… so maybe a video card specific thing - what is the video card on this machine?

-Pascal


#3

It looks like a video card thing. On GTX 950M is ok, on 940M (Surface Book) not.


(Wim Dekeyser) #4

It’s not working here (and has been like that for the longest).
Quadro K3100M

Simply showing something that was hidden resolves it:

CC: @jeff


(Jeff Lasor) #5

This is on my list, and is getting worked on at the moment.


(Jeff Lasor) #6

@wim This should be fixed in tomorrow’s WIP…thanks for your patience on this one… It finally bubbled to the top of my list and stayed there… It kept getting preempted by other, more serious issues. As far as I can tell, this exists in V5 as well…so ya, it’s been in there a long time :slight_smile:

-J


#7

Hi Jeff.
This is not entirely fixed. Objects inside blocks still have problems.

The cut edge for objects inside blocks is missing when they are not in the view when the clipping plane is created. (same as before)
Also the cut surface is missing for the boxes inside blocks.

Geometry outside blocks seems to be fine.

(6.0.17136.10381, 16/05/2017)


(Jeff Lasor) #8

This is actually something entirely different from Wim’s issue. This now has to do with blocks and nested blocks. The end results and/or artifacts might look the same, but for completely different reasons.

I have filed a new bug item for this…

https://mcneel.myjetbrains.com/youtrack/issue/RH-39385

Thanks,
-Jeff


#9

This would be useful for architectural design since wall types and thicknesses change constantly according to fire,sound requirements, finishing etc etc. Doors and windows the same, they already come as blocks when imported from Revit.
For this reasons it is very convenient to work with blocks and to see them sectioned in 3D and in 2D for plans.


(Jeff Lasor) #10

@Bogdan_Chipara This should now be fixed in this week’s WIP (assuming there are no hiccups with the WIP release)…Please let me know if you still have issues with blocks.

Thanks,
-J


#11

Hi @jeff . I still have the same problem. If i create the clipping plane when the blocks are outside the view, when i move the camera and i bring them into view the cut edges and surfaces are not showing up.

(6.0.17150.8211, 30/05/2017)


(Jeff Lasor) #12

@Bogdan_Chipara even after you release the mouse? Do the blocks already have their render meshes created?

I guess the best thing to do is to post a file here, with exact step-by-step instructions…because I’m just not seeing the problem here.


#13

Ok, here are the steps:

  1. switch to shaded
  2. maximize perspective mode
  3. create a box and block it
  4. copy the block instance around several times
  5. zoom in so only one instance is visible
  6. add the clipping plane
  7. zoom or pan using the mouse to bring all the instances into view. (the other instances are not displayed correctly)


(Jeff Lasor) #14

@Bogdan_Chipara
That’s exactly what I did prior to responding… Everything works as expected. Are your Shaded mode settings at their defaults? I’m just wondering if it’s some display setting you’re using that could be messing things up…

Here’s what I get:


#15

I don’t remember ever changing the settings for shaded, I will have to check. What is strange is that the objects outside blocks show up perfect. Only the ones that are inside show up wrong.


(Nathan 'jesterKing' Letwory) #16

You may want to reset your display modes, even if you didn’t make changes.

Changing a display setting on an active viewport triggers a display mode attributes save for all existing display modes. With the WIP changing still quite frequently it happens that settings “change”

/Nathan


#17

Ok, I installed release of today and I also reset the display modes.
The issue got fixed for blocks with the steps described above.

But the bug persists in other situations:

  1. switch to shaded

  2. maximize perspective mode

  3. create a box and block it

  4. copy the block instance around several times

  5. zoom in so only one instance is visible

  6. add the clipping plane

  7. zoom or pan using the mouse to bring all the instances into view.
    ( the blocks are now showing up correctly)

  8. zoom in again so only one block is visible

  9. double-click on it to open block edit

  10. switch the box inside the block from Shaded to Ghosted and close block edit

  11. zoom out again to see all the blocks
    (the blocks which were not visible in the view don’t show up correctly)


    (6.0.17157.8191, 06/06/2017)


(Pascal Golay) #18

Hi Bogan - thanks for the blow-by-blow, I can repeat this exactly as you describe.
For now, if you move one of the block instances the display seems to correct itself.
https://mcneel.myjetbrains.com/youtrack/issue/RH-39675

-Pascal


#19

The problem is only related to Ghosted.
I switched back and forward between other display modes but they seem to work fine!

Thanks!