Edges disappear beyond Clipping Plane


#1

Creating a separate thread for this specific problem.
Any geometry beyond the Clipping Plane has not Edges. Here’s an example. Default Shaded display mode.

FYI - I do have Vray. My Renderer is set to Rhino. SysInfo below

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Commercial, build 2018-11-07
License details: Cloud Zoo. In use by: Alan Farkas ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-NUQN85K

GeForce GTX 980 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version: 23.21.13.9135
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.9.26.937\SectionTools.rhp “SectionTools”


(Pascal Golay) #2

Hi Alan - I do not see that here:

Is that what you’d expect to see?

-Pascal


#3

Yep.


(Pascal Golay) #4

Hi Alan - does your display mode have any custom backface settings? What happens if you use a mode set to defaults?

-Pascal


#5

That was the Default for Shaded.

But I just tried it with Pen, Technical, and some custom ones I had made from a while ago, and it looks ok. Weird, no?


(Pascal Golay) #6

Yes… does this happen with a new, very simple scene?

-Pascal


#7

And on that note - Should I be able to use the Clipped Section line (where the clipping plane hits geometry) as a Dimension pick point? Because I can’t.

I’d like to (sometimes) use a saved Clipped view in my Layout page and dimension in Layout space. But if I can’t dimension to the Clipped plane, it makes it difficult.

But seems to work ok in FRONT view in Layout (ignore that the inner box seems lower in the “Front” view image. I moved it to see if it still worked even when partially inside another piece of geo)


#8

yes, happens in this simple scene I made with the cube in a cube


(Pascal Golay) #9

Hi Alan - it seems to work in Front because the snaps are dropping back to the box corners - if the box were skewed, you’d see the problem. You can fake it:

  • turn on History
  • Intersect the clipping plane and the objects
  • when you’re ready, set a CPlane to the clipping plane (CPlane > Object)
  • Dimension to the curves resulting from the intersection.

-Pascal


#10

Missed this, thank you, I’ll try it.

Will this work in Layout dimensioning?

ALSO: What about the Edges disappearing beyond CP?


(Wim Dekeyser) #11

Hi Alan,

I’ve seen another report of this but cannot reproduce this on my systems.
You can override display mode settings in the Display panel without this changing the display mode - is it possible that something like that is going on?

Also, you mention that it works fine in other custom display modes? Are these all modified copies of a display mode that uses the Technical Display Pipeline?


#12

I think I had missed that question, sorry. Yes, a simple box and it’s still a problem.

I’m going to try it on my laptop tmrw if I remember and see if it happens there. (I’ve been using my desktop)

UPDATE: Does not happen with my laptop. Maybe time to update my Desktop computer.