Object Snap not using foremost objects but gets lost in complex background objects

I have a major issue working with a rather complex model.

I use object snap usually persistent and have it tuned to the details I want it to snap and rarely have to use “single” with most models - it will work just fine and I have very reliable object snap functionality.

Now I am working on a project with a very complex model and from all the CAD software I have used over the years a certain workflow to snap on a specific object has been burned into my brain:

  • use shaded model view to enforce object snap priority always on visible foremost objects and ignore objects hidden by shaded objects in the foreground
  • when wanting to snap on an object that is positioned in the background just switch to wireframe view and snap on anything you like

At the moment this logic is not working and Rhino will snap on ANYTHING, be it visible in the foreground or hidden in the background and I have a really hard time snapping on the desired objects (and mostly have to fall back to work in wireframe view only and zoom very strongly into the detail I want to snap on to make sure I grab the correct object.

This is as you can imagine VERY time consuming, not helped by the fact that the model is so complex that working on it by itself is rather slow.

Is there something I am missing here?
Does the issue lie in the complexity of the model?

To get a feeling about the complexity: The model has broken into in single surfaces more than 10000 surfaces and does render very sluggish when broken into single surfaces.
When joined into a solid (which is how I work most of the time if I can) it renders ok but not 100% fluid.

I am on the rather restricted MacBook Pro to work on this one on an external 4K screen, not on the big computer.

do you mean by “single” actually “one shot” ?

the option to snap to visible objects was implemented in the rhino 6 WIP for Windows
and will probably be coming to Mac then either some day.

till then you have to use one shot to hit the object rather, this by the way can also be typed into the value during a command so you dont have to click “one shot” in the osnaps to activate the snaps there. might be a bit faster. on mac it unfortunately does not autocomplete yet.

Thanks for the info Richard!
I was completely unaware of that and thus far probably just not realized it as I got away without issues (I also tend to use hide / show a lot which probably helped).

I do not understand how to quickly invoke quickly “one shot” osnap (I use 99% of the time keyboard bound commands and basically type my way through CAD but I do have the osnap panel always visible below the main tool palette, so actually mouse clicking through it is what I do currently).

I could swear though that osnap has worked the way I thought it should thus far by only selecting visible objects when in shaded mode - did it really always select ANYTHING visible and invisible behind shaded objects?

I happened to create a post on this in another thread by RichardZ: String Autocomplete

Try switching off Isocurves visibility: Preferences > Display modes > Shaded (or Ghosted), I use it that way and I see the behaviour you want. But it depends what you are doing, selecting the object beforehand or after starting the command. In the latter case, i.e. drawing a line, it will still snap to points that are hidden from view by another object.

Max.

Thanks a lot Max - I like the way you think re. creating a custom palette and shortcut to it :wink:
I cannot work without ISO lines visible, it would drive me nuts.

I also found another issue with Rhino + Osnap. When Osnap is active performance with very complex models is absolutely abysmal. Just switching Osnap off will render the model perfectly fluid, so I have mapped this function now to a button on the space mouse, speeding up modeling a lot.

Thanks for your tip re. custom palette - I keep that in mind and might use it for other uses as well.

In modelling aids section of options disable Snap to occluded.

(Assuming this bit works the same on the Mac)

Nathan, this option sadly is not available in the Mac version.

I have now as a workaround reduced the Osnap radius from 15 pixel (standard) to 10 pixel and see how this goes.