OBJ Export (use render meshes option) is ignoring Edge Softening

Hello, It’s nice to have “Use render meshes” in the OBJ export, but unfortunately, it loses some stuff in the process. It is not including effects such as Edge Softening. On the right, you can see that the Extract Render Mesh command gives me expected results - correctly mapped and softened mesh.

meshe testy rhino 8.3dm (2.1 MB)

Tested in Rhino 7 and Rhino WIP

Nothing predicts upcoming problems


Export settings

How it looks in Blender

Important: If during OBJ export, you don’t use the “Use render meshes” option, you might get softened mesh but good luck with texture mapping…

1 Like

I wish I found this relation earlier… Thanks for pointing it out.
Extracting render meshes in Rhino before the export is not the best way for multiple reasons.
Also, it’s breaking every workflow based on the Object ID such as Datasmith export to Unreal Engine.
I hope it can be solved soon. Is there someone specific that I can ask for the help in that matter?