Nvidia GeForce 1080Ti doesnt work properly with Rhino 6 Vray 3.6

Hello All,
I am new to Vray for Rhino 6 and just started testing my GPU machine. I found out that my GPU doesn’t work while rendering no matter if the option GPU is selected. Then my CPU is awfully overloaded.

my sytem info is:
Rhino 6 SR5 2018-6-4 (Rhino 6, 6.5.18155.13161, Git hash:master @ 0e00e118078ee9a651d609817f672fb0ed8e83bf)
Licence type: Educational, build 2018-06-04
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-512G927

GeForce GTX 1080 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.11)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-1-2018
Driver Version: 24.21.13.9811
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

My current render settings are set to my graphics card (as you can see at my screenshot below). In these settings, in the Raytraced viewport I can’t see whether the device is being used or not.
(The selected render setting should be seen on the bottom of the viewport.)

RhinoCycles_ListDevices is here:
Command:
RhinoCycles_ListDevices We have 2 devices
Device 0: CPU > Intel Core i7-8700K CPU @ 3.70GHz > 0 | False | True | CPU
Device 1: CUDA_GeForce GTX 1080 Ti_0000:01:00 > GeForce GTX 1080 Ti > 0 | False | True | CUDA

please, can you tell me, where can be a problem? I put a lot of Money into this graphic card and it doesnt work as I was expecting. I will be glad to hear solution.

First thing, that’s not Vray, that’s Rhino Cycles, completely different.

Second, how do you know your card isn’t working? From the time readout on the raytraced display, that seems to be working. The basic “Rhino renderer” doesn’t do GPU rendering(at least not until it gets replaced with Cycles,) and Vray is it’s own thing.

I have read many forums (it lasts for one month) and I really do not know, why I can not render with GPU. I am completely lost in settings, don’t know where to look for a bug. I tried to do something in my settings in my graphic card control panel, but nothing works.

In the Vray message window after GPU rendering:
./src/ocl_tracedevice.cpp(3246) : CUDA error 2 : unable to allocate enough memory to perform the requested operation (out-of-mem)

From your screenshot I’d say your GPU is being used for Raytraced, since you get 1000 samples done in 23 seconds.

If you want to render with another engine like V-Ray using the GPU you’d better not use Raytraced in any viewport. It takes GPU memory, and that may cause V-Ray to not have enough.

That said, you can of course use Raytraced when not using V-Ray… :slight_smile:

/Nathan ‘Raytraced dev’ Letwory

Yes, sure i dont use Raytrayced viewport for rendering. For better understanding I put my screenshot from my display. There you can see my problem.

1 Like

You should use GPU-Z or MSI AfterBurner to check your GPU utilization.

The taskmanager shows only the GPU usage for the UI drawing, not non-GUI utilization like raytracing with CUDA or OpenCL.

OK, thank you. The GPU-Z shows quite different numbers. The render isn’t so good, but at least it does work. Thank you

The Vray message window says:
​Error 716 while intializing context for device GeForce GTX 1080 Ti! Device will not be used for rendering!
There is no device supporting at least CUDA 2.0!​

Always happened after GPU rendering

What is wrong then?

Sorry, you’ll have to ask the chaosgroup people. I’ll move this topic to the V-Ray subgroup.

same problem

​Error 716 while intializing context for device GeForce GTX 1080 Ti! Device will not be used for rendering!
There is no device supporting at least CUDA 2.0!​

Please make sure your GPU device is supported and its drivers are up to date. (https://docs.chaosgroup.com/display/VNFR/System+Requirements)
Also, double-check it is enabled in the Asset Editor’s device selection list (the button next to the GPU engine selector) .
If the issue persists with the latest drivers, please reach out to support@chaosgroup.com with info about your OS, GPU device and driver version as well as full version number of V-Ray.

Kind regards,
Peter Chaushev
V-Ray for Rhino QA
www.chaosgroup.com